Sync to Nextcloud error: ".lock/ not in baseUrl"

hello there,

Joplin 1.0.199 on Kubuntu 18.04 doesn’t seem to sync with Nexcloud 18.0.3. The following message appears just above the “syncronize” tab:

"Completed: 19/04/2020 21:24
Last error: Error: href /cloud/remote.php/dav/files/xxxxxx/Joplin/.lock/ not in baseUrl nor relativeBaseUrl /cloud//remote.php/dav/files/xxxxxx/Joplin"

Tools>Options>Syncronization>Check (on the address confirms “Success! Synchronisation configuration appears to be correct.” The encryption option is disabled.

After (not)completing the sync, the folder “Joplin” on Nexcloud says “3 folders (including 3 hidden)”. These folders are: .lock, .resource, .sync. It doesn’t show anything else, i.e., the test note I created on Joplin hasn’t been synced. The sync seems to take a rather long time (internet connection is good).

(sorry, I don’t understand

can you please help? Many thanks in advance.

You have 2 slashes in URL here:

Tools>Options>Syncronization>Check (on the address

is it configured exactly like this in Joplin? If so try with one slash?

many thanks roman_r_m! it worked now. Sorry I totally missed that extra slash!

a quick question - sorry it’s not clear to me: when I now check the Joplin folder in Nexcloud, I see 13 files (extension: .md) for one note synced. Is that normal, i.e., the sync provides a back-up of notes and saves it in Nextcloud, and I still need a deskotp client or an Android app to read my notes?

I might not be the best person to answer this but I believe Joplin stores files not only notes but also metadata: history, conflics, attachments, etc.

In theory you could open those files with any text editor but I would advise against it - you can only edit note text but not metadata (you could edit it in theory but in would not be practical).

Yes, changing files on the sync target directly is a no-go. Theoretically it could be done, if you knew the internals of how the sync process works, but it is not supported and a sure-fire way to screw up your data.

1 Like

understood. Many thanks for your help!