Sync to filesystem says successful - but there are no files!

Version: 2.11.11 on Linux (Manjaro, Flatpak)

So, this is weird.

I am trying to set up a Filesystem sync.

I set up the sync target, then hit sync...and it shows all the objects being copied as expected, then a completed notification. Cool.

However - there are no files in the target directory!! (My knowledge level re: file systems is fairly high.)

When I sync again, it obviously sees the objects is synced previously, because it only updates changed objects (or nothing, if no changes).

I initially tried this with a directory that's on a separate partition that gets synced with Syncthing, but then tried a subdir right in my home, same problem. I deleted the entire set of config and data directories in .config, still does the same thing when I set it up as a new Filesystem sync with default data.

I even tried from a different computer (same OS and package version), same issue.

This is quite maddening...

WHERE are my files going? They're going somewhere, but I have no idea how to find out where!

Since it's flatpak, I was wondering if it's somehow getting synced to the sandbox, but I didn't see anything in ~/.var/app/net.cozic.joplin_desktop/config/Joplin/ to indicate that's what was happening...


You should test with the officially distributed appimage package, just to rule out a flatpack sandboxing quirk.

Joplin doesn't do anything funky with the filesystem sync, so I bet the issue is something related to the flatpack sandboxing.

Welp - of course that works. I think I looked briefly to see what other packages were available, but missed the Appimage (didn't look at the github releases, derp.)

I don't know if someone can work with the flatpak packager to fix that, maybe make the flatpak work correctly. I realize probably not, but if there's any chance it might save others some trouble.


1 Like

Have you ever checked these links?

The issue wasn't with file access, per se - I can save/restore a backup from the local filesystem, same places I'm trying to sync to. So, I'd assume the same should work for sync.

The weird thing is that the sync SAYS it works - it's just that there's no files there, and I can't really find where it's putting them to check to see if it's actually syncing with another device :confused:

But, to be clear, I've resolved this by using the Appimage, though I'm happy to help if anyone wants to resolve the flatpak issue.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.