Sync errors with both Dropbox and OneDrive (self signed certificate)

Yes, I would to do that for onedrive…

This worked for me as well. Same conditions: fresh install of Joplin under Windows10 and the certificates problem; Went to Tools > Options > Synchronization, selected WebDAV, checked “Ignore TLS certificate error”, Apply, changed back to DropBox, Apply, and then I synchronized and it worked.


Thanks! That was the trick. Go to WebDAV and check "Ignore TLS certificate error" then switch to the way I wanted to sync!


Thanks ! Needed also that trick because my company FW is messing with certificates. :frowning:

Yep I also had the same issue. Had a fresh install of Joplin to my personal Windows 10 laptop (note: not a work PC like others in this thread) and set it up with OneDrive and it failed while syncing with an error that said it was "unable to get local issuer certificate". Going into the advanced setting for WebDAV and enabling "Ignore TLS certificate errors" allowed Joplin to successfully sync with OneDrive. Would suggest moving this checkbox out of the WebDAV synchronization advanced settings like the OP suggested since this seems to be a more widespread issue.

Has anyone had luck determining which certificate was causing the issue or bypassing this without fully ignoring TLS errors? I've been trying to use the custom TLS certs field under WebDAV to work with OneDrive, but it doesn't seem to recognize them and the error that I can see is almost no information. The URL that is failing in Joplin works perfectly in a browser that is using my local cert store.

Thank you for the tip. Using Joplin on the latest OSX and this was what finally got Dropbox to sync up.

Thanks for covering this.

It seems like the earlier poster's suggestion to move that setting out of the WebDAV section (or at least duplicating it in the other sections where it applies) is a good one.

is there any reason why it is not available if you connect to Joplin Cloud?
In my case all data goes to Zscaler Proxy (Zscaler Private Access) to analyse even https traffic.
For that purposes on each office machine, a custom Root CA is installed.

I've just started using Joplin :slight_smile:

I had the same self-signed certificate issues reported in this thread. I am using a corporate laptop, and managed to get everything to work when I temporarily disabled one of the security tools (Netskope Client). After turning Netskope back on, synchronisation failed. So I have to disable Netskope whenever I want to synch. Not ideal, but it does work !
Apologies if this information is redundant and/or already known.


Please consider OneDrive users who need to utilize SelfCertificate, such as Zscaler Proxy (Zscaler Private Access).

Thank you. This pull request #8980 has already been submitted for S3 sync. Perhaps this solution is appropriate for the current issue.