Sync error: Network request failed

I've checked other similar posts but this issue may be a little different. The remote Nextcloud server is Swiss.

I have two de-googled Android devices, both with new installations. Joplin 1.7.2 on an Android 8.1 phone works perfectly. Joplin 1.75 on an Android 7.0 tablet always returns the sync error "Network request failed." The Nextcloud WebDAV URL, username and password are identical in both instances (checked a gazillion times).

Could some kind soul suggest what I try next? Thanks!

Please provide logfiles.

Thank you for your input!

Please post the complet log as file or in a code block, not as img and also the console window output.

OK, is this the one? Thanks for your help!

syncReport-1623571849039.txt (18.1 KB)

Synchroniser is missing credentials - manual sync required to authenticate.

Are you sure that WebDav is configured with user and password?

Could you update to 1.8.5

I'm a bit out of my depth here, but I'll try. On the tablet, I use DAVx5. Everything else (calendar, contacts etc.) syncs fine.

v1.8.5 now installed.

Here's an updated sync report:
syncReport-1623743574532.txt (29.0 KB)

Thanks again!

The DAVx5 has nothing to do with the Joplin configuration!

You have not configured a syncronisation.
Please configure the Sync in Joplin under Configuration > Syncronisation

Oops! Sorry! Try again:


syncReport-1623756051266.txt (32.1 KB)

Try version 1.8.x just in case

1.8.5 installed before last sync report.

Right sorry, I read the first and last post and missed the ones in between. These Network Request Failed errors are very hard to debug and are usually due to some low level issue. I have no idea what to suggest to be honest. Even if you look at the device network log, it's unlikely you'll find any additional info.

1 Like

Maybe try with "Ignore TLS certificate errors" enabled. Although it does not seem like your server is using a self-signed certificate

OK, enter your sync config details and press save, not check CECK SYNCRONISATION CONFIGURATION.
Then make a manual sync, and post the error and the logfile.


syncReport-1623828586775.txt (38 KB)

This syncreport was made by clicking Export Debug Report in Joplin. Is that OK?

Sincerely appreciate your continuing interest, tnx!

Have you enterted your settings and then pressed save and then triggerd a sync?
Because in the Log there is no information.

I found the Save button OK but I'm not sure about the "manual sync." I did find a "Manual" option for "Attachment download behaviour" but maybe that's not the one you mean.

Can I trigger a sync without pressing Check Synchronization Configuration?

I also found and enabled "Ignore TLS certificate errors" suggested by roman_r_m.

Trigger sync:

OK, I think I've got it now. I entered sync config details and pressed save. I didn't Check Synchronization Configuration but made a manual sync. I then exported this dbug report:

syncReport-1623925632770.txt (54.1 KB)

Thank you for your patience!

OK, there is a network problem.

06-16T20:06:25,10,"""TypeError: Network request failed
value@[native code]""

Android 7 no longer supports all common SSL ciphers / protocolls. So I'm not sure if that's the problem or a other network problem.

Could you open the URL in the browser on the device?