Home    |    GitHub Page    |    API    |    FAQ

Sycing with joplin folder rather than joplindev folder in one drive/dropbox from joplindev app

Hii I am new to this forum and the repo but already a joplin user.
Right now I want to create a conflict to fix a bug. The conflict is created in the prod version of the application but I want the dev version to have the conflict to fix the issue #3997. But the problem is that the dev version is synced to the joplindev folder and not the joplin folder due to the which the Conflicts is not being synced. Can anyone help me as how I can create the Conflicts in the dev version

There's a development-only flag you can use to point to the regular Joplin config folder: npm start -- --profile ~/.config/joplin

Hi, thanks for the help but the flags are not helping in syncing with the preexisting joplin folder in one drive.
As of right now after using the flags I did the whole sync thing again but nothing happened it is still creating the JoplinDev folder in the onedrive and syncing with that folder only. is there any other approach to it so that I can sync it to the Joplin folder.

onedrive_joplin

One thing you could try is just copy the directory with source code and run another copy of (dev) Joplin from there and sync between these two.

I do not think there's an easy way to sync between JoplinDev and regular Joplin. At least with Dropbox these are essentially 2 different apps, I suspect this is the case with OneDrive as well.

HIi @roman_r_m I've copied the joplin dev app in two places but when I hit the sync button it says not a valid url in both the copies can you tell me how can I reset the one drive access links in both the copies

Btw am not using the development flag (npm start -- --profile ~/.config/joplin) here

Looks like my suggestion isn't going to work.
I assumed that Joplin dev keeps its profile next to source code, but I was wrong -- it's in ~/.config/joplindev-desktop (on my system) so both copies share the same profile.

@roman_r_m quick update: I successfully created the Conflicts but for that I had to clone the repo again in another directory (means two repo in different directories then It worked).
But Now I have another problem I have just updated one of the local repo but seems like the old files are still there. Can you tell me how I can remove the old folder since in the original one everything has been move to packages folder.

folder like CliClient and others are extra here from previous version can you tell me how I can remove them

git clean -f maybe?

@roman_r_m yeah that didn't work anything else maybe..... @laurent can you tell me how I can remove the old file.
git clean -f didn't worked somehow. Can you please also tell me the right way to update the repo.

Right now I have two local branches dev and contribute. I fetch the upstream to dev then rebase upstream/dev and then force push the changes to remote repo and atlast merge changes to contribute.
Please tell me if I am doing it right and how I can remove the old files

If nothing else works you can just delete those folders yourself

ok sure thanks I will do that