First conflict ever and a mistery

I am using Joplin 2.13.2 on a mac, sync to nextcloud, and I do not sync to any other device(s). This is certainly part of the reason why I never experienced sync conflicts.
Anyway, I also installed the "conflict resolution" plug-in a while ago. And today this shows an orange banner on top of the Joplin window saying that resource such-n-such has a conflict and cannot be uploaded. But that the conflicting resource would remain available locally.

  1. First I tried to see if uploading the whole profile again to the sync target (through the mechanism provided in settings) would solve the problem - it did not.
  2. Next, I located the file and tested what happens if I remove it (I have a backup). In that case no further errors in Joplin.

Good, problem solved BUT since the conflicting file is encrypted (and file size is 250kb - not zero) I cannot figure out it's original contents or purpose, or what information I am loosing with this solution.
Would anyone have an idea how this could have happened in the first place, and how to fix it ? Or at least how to identify which note was contained or affected ?

Nobody any clue ?

Really nobody ? My guess is, the scenario how such an error might happen (and that it can happen at all) might be in the interest of other users too.
Has anybody had a similar problem ?

I never heard about this 'conflict resolution' plugin,, nor installed something like this.
Still I use a common Joplin instance between three machines and a Dropbox account. (and this twice, as my SO does the same separately)
When there are conflicts (i. e. in my case when I edit the same note on two different machine without sync'ing them), Joplin automatically creates a 'conflicts' folder, both sides, which contains the alternate copy of the problematic note.
When I see this I open both, locate the conflicting changes, and generally copy what I want to retain back to the original note, then delete the folder.
For me this always worked fine.
I suppose there may be other causes for conflicts, but here stops my experience.

1 Like

Appreciate your description and comments ! Thanks

Well In this case I use a compare Editor like VS Code / VSC odium then open the conflict file with 'Toggle external editing' Button, doing the same for the Original file in VS Code use 'Select for Compare' fix the issue in the Original file and delete the conflict file.

But this should work as well Conflict Solution

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.