Switching between Markdown Editor & WYSIWYG -- Behaviour Line Breaks & Bullet Lists


I'm new to Joplin and hope it will be my all time favourite note-taking app soon. I'm also new to markdown, my question might give that away anyway.

I'm using Joplin 1.7.11 and intend to mainly use the Markdown editor.

Yet, I switch from the markdown editor to the WYSIWYG view from time to time, for example to view pictures I've included in markdown.
There's 1 bigger thing that disturbs me and one minor one, and I hope, you can help me.

The bigger thing is how the Markdown editor and the WYSIWYG editor handle line breaks, but also that the WYSIWYG alters my markdown document.
I'm used to structure my documents using a lot of line breaks, e.g. between paragraphs, but also between small text blocks, under headlines etc. Sure, i could adapt the CSS to add more space unde paragraphs or above Headlines or so - and I might do that - but i want to work with line breaks from time to time to be flexible.
This works fine in the Markdown editor by adding line breaks just pressing Enter, say 3 times. But the WYSIWYG editor doesn't render the additional line breaks, it shows 1 line breaks, but not 3. So document strucutre gets lost in this view.
Is there a way to make the WYSIWYG editor render additional line breaks? Or do I have to input the line break differently in the markdown editor?
I wouldn't really want to add "<.br/>" or "&.nbsp;" in my markdown notes, because it makes that one less readable..

What bothers me more about this is that if I have say 5 line breaks in markdown which help structure my note and I switch to WYSIWYG view, which doesn't show these anyway, and I switch back to markdown, they are gone for good also in markdown view, which really annoys me.
So switching to WYSIWYG and back to markdown, my line breaks are gone for good. What can I do about that?

Less bothering but similar behaviour:
I use to write bullet lines in markdown with an asterix, *, which I think is standard. If I switch to WYSIWYG and back to markdown, the bullets, formerly " * ", change to " - ". I don't really like that either, I thought * was standard for bullets? Is there a way to stick with * instead of - in Markup editor permanently?

Any comments and ideas?

Thank you!

Hi @penfold

There would have been a warning banner when you first opened the WYSIWYG editor alerting you of these shortcomings.

Since you primarily use markdown, I would suggest using the markdown viewer instead of the WYSIWYG editor. You can toggle the viewer with Ctrl+L or by clicking the icon in the top right that looks like two side by side rectangles.


@penfold welcome to the forum.

As @CalebJohn says, if you are using the Markdown editor to create your notes, rather than use the WYSIWYG editor to see your notes, it's probably better to use the Markdown editor's viewer pane. You can then see your Markdown and how it renders at the same time. The pane is activated using (1) in the picture below. What this button shows can be controlled using options that can be set at (2). The picture below has Joplin in "Split View".

Joplin will accept asterisks to create bullets and they remain as asterisks if you use the viewer pane and not WYSIWYG (3).

Markdown itself does not allow multiple blank lines when rendered. So you may put multiple blank lines in the editor (4 & 5) but when the Markdown is interpreted no lines are shown if the blank lines are at the start of the note (6) or one line if it is between text (7).

However using the Markdown editor and viewer pane (rather than switching to WYSIWYG) does mean that you will not lose those extra lines in the editor.

Please ignore the fact that my copy of Joplin may look a bit different from yours - missing buttons, different text sizes and colours, added note tabs - my copy has been customised


That's pretty much what I do except for when it comes to tables. So much easier to create and edit tables in WYSIWYG than in markdown.

1 Like

Quick addition (based on my experience, no guarantee): Switching to the WYSIWYG-editor just for viewing should not change the note in any way. As soon as you alter the note in the WYSIWYG-editor, it stores the changes, and that's when the things it cannot deal with are lost.

Regarding the line breaks, and just FYI (as it does not solve the WYSIWYG-problem that you are facing): Multiple line breaks are not a feature of markdown as noted above. However, many viewers display lines with a single \ as a new line as follows:

This is some text.
This is some other text.

gets rendered as follows:

This is some text.

This is some other text.

Now this is less elegant than simply using empty lines, but would allow you to have multiple empty lines both in the editor and viewer if you follow dpoultons solution.


Hi all,

thanks so much for your quick and detailed answers. I read them right away (they didn't go to waste), but I didn't answer before now since obviously I'm not used to an active community the way you are. It's very motivating to have such an active, helpful community, even for such a basic question, thank you!

So after all, I think I will have to see how i will deal with how markdown gets rendered - it obviously is not a shortcoming of Joplin but I guess my style of writing, using a lot of line breaks, doesn't quite match with how markdown is rendered.
So I try to adapt my writing style a bit, I might also try the \ as line breaks, which is not quite pretty though. I would have found that easy to accept, if it would work with one line break before \ and one after, but unfortunately, if there's a line break after , it's not rendered as a line break but as a character like this

Markdown Editor:




Markdown Preview:

Text 1


Text 2

I find that accetable in the editor but don't quite love it in the preview, but might use that anyhow.

Also, the rich markdown plugin some user has released recently is quite helpful to maybe get rid of the markdown preview after all (though my 'problem' would persist when exporting, but still..!).

Also, as @philip-n pointed out, if I don't alter the note in WYSIWYG, it isn't being altered in the markdown editor. So as long as I'm not touching that, I don't have that frustrating experience, which was my main concern to begin with.

Thank you for your help!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.