Spell check should turn off when writing math formulas

Operating system

Windows

Joplin version

2.14.20

Desktop version info

[Window Title]
Joplin

[Content]
Joplin for Desktop

Copyright © 2016-2024 Laurent Cozic
Joplin 2.14.20 (prod, win32)

客户端 ID: 5961821c58354472bfe86cfe5f27143c
同步版本:3
配置文件版本:46
支持的密钥链:是

修订:cfd98e3

Backup: 1.4.0

[复制] [确认]

Editor

Markdown Editor

What issue do you have?

When I use KaTex in markdown to write math formulas, I notice that spell check is also working which cause many ugly wavy lines(see the screenshot). I think spell check should turn off when writing math formulas.

Screenshots

I suggest trying the beta markdown editor (Settings > General > Opt-in to the editor beta) — it should disable spellchecking in both math and code blocks.