Line spacing: how not to have empty space?

Operating system

Windows

Joplin version

2.14.20

Desktop version info

Joplin 2.14.20 (prod, win32)

ID client : 06ce77b02f7b43678e371661ffc12a0e
Version de Synchro : 3
Version du profil : 46
Trousseau supporté : Oui

Révision : cfd98e3

Backup: 1.4.0

Sync target

Joplin Cloud

Editor

Markdown Editor

What issue do you have?

I've had this problem since yesterday and I can't find a solution. Can anyone give me the solution.

It's not clear what's your question, could you please provide more information?

Good morning,
I will try to tell you in a few words what I would like to achieve when I create notes with Joplin.

What I currently get:

Screwdriver

Hammer

Drill

Plane

What I wanted and would like to get:

Screwdriver
Hammer
Drill
Plane

By entering each word (or group of words) and moving to the next line with Enter.
Currently, as you can see, the spacing between lines is abnormally large.

Sincerely

Hi lechevalier,
please give Shift+Enter instead just Enter a try.
Best!
Wim

Good morning,
Thank you for your reply. It actually works.
Too bad just pressing Enter doesn't do the same thing.
As I am a beginner and would like to learn more, especially for the basic functions, I would like to ask you if there is a good tutorial for beginners like me.
In any case, I think I will definitely opt for Joplin.
He deserves to be better known.
Sincerely

Spacing can be manipulated with CSS.

If you are talking about the rendered view, you can play around with the settings for margins and spacing. Add this to the top of your document to test and tweak as needed …

<style>
    /* These are, I believe, the defaults. Adjust them as you see fit. */
    body {
        line-height: 1.6
    }
    p, h1, h2, h3, h4, h5, h6, ul, table {
        margin-top: 0.6em;
        margin-bottom: 1.35em;
    }
</style>

Once you are happy with the look, edit userstyle.css (Options > Appearance > Show Advanced Settings), remove the <style> thingies, and add the tweaks you just made. This will make it style for all of your notes. (note, you have to restart Joplin to have those changes to the file take effect) …

/* These are, I believe, the defaults. Adjust them as you see fit. */
body {
    line-height: 1.6
}
p, h1, h2, h3, h4, h5, h6, ul, table {
    margin-top: 0.6em;
    margin-bottom: 1.35em;
}

not a tutorial, but you might not have seen this page, so … better than nothing hopefully!

Thank you for your reply
Sincerely