[Solved] Search should just work!

Dear Team,

First of all, thanks a lot for this wonderful program. Really love it, its been just a few days since I installed and I am already so damn used to it!

The workflow below is to search for a word within a note (global/ local search):

Create a notebook NB, sub notebook SB1 underneath NB and SB2 underneath SB1
Add this word as a note at SB2 level “Antidisestablishmentarianism”
Search for it using Search in all notes/ current note, but the result wont appear
Joplin says “No notes in here. Create one by clicking on “New note”.”

Is this because of the length of the word?

Welcome to the forum.

Not a dev just a user. I used a "clean" version of 1.0.193 portable on Windows 10. I deleted the default notebook then created NB, then SB1 in it then SB2 in that. In SB2 I created a note called "Search Test" containing just the word "Antidisestablishmentarianism". I then moved to the empty NB notebook and used the search bar to search for "Antidisestablishmentarianism". Like for to you, nothing happened. I navigated back to the note and then back to NB. From that point onwards the search did work. Also despite deleting the NB notebook and starting over again it continued to work. So it isn't the word length! Is this search still failing on your setup?

I also tried with the pre-release verion (1.0.194) and I couldn't get the search to fail at all.

Finally, if you do ever need to ask for a bit of help on the forum, letting people know what Joplin version and OS you are using can be quite helpful... :slightly_smiling_face:

Can also confirm that this works correctly with Joplin 1.0.193 on Linux, tried putting it in both the title and the body. What OS and version are you running OP? Could be a bug isolated to one version of the application.

If it does work eventually, but not immediately, it probably just needs a few seconds to index the newly created note.


I can only reproduce this if the first thing I do after creating the notebooks and note is search for "Antidisestablishmentarianism". If I do nothing else but just re-enter the word and search again it works. Also I cannot reproduce this once I have previously created a notebook, any notebook, in Joplin with two stacked sub-notebooks. I could only trigger it again by using the same process but in a notebook with three stacked sub-notebooks. So it looks like Joplin just needs a little bit of time to adjust its indexing, as @jamedeus suggests, when deeper and deeper notebook "stacks" are created for the first time.

Hopefully your search is working now...

I’m not sure, but the search index might only be updated periodically. If so you might need to wait a while before you can find it in search.

Dear @dpoulton, @jamedeus, mic704b (sorry new users can only mention two)

Like you all have suggested, it takes a while to index, and per @dpoulton 's comment, we may need to get back to the note and then to the NB if we’re searching for it immediately after typing in (kinda giving time for indexing I guess)… But it works great!!! Finally I found a better version of Notational Velocity but with so much more

Above and beyond the solution, I wanted to say this group totally rocks. Thanks a lot guys. I hadn’t expected someone to respond so fast. Thank you!

Will change the subject of this to solved… Have a safe day, Cheers

1 Like