Setting up an development enviroment in Linux and Windows VMs

do make myself familiar with the codebase but ensuring that erros are not due to my local config, I’m creating a Win and Ubuntu VM.
I’m done with Ubuntu Setup


  1. Install Ubuntu Desktop minimal (install option)in a Hyper-V using the desktop install image:

  2. sudo apt-get update and sudo apt-get updgrade

  3. Install tools to use Enhanced Mode

    1. deactivate auto-login
    2. Onboarding: Ubuntu · microsoft/linux-vm-tools Wiki · GitHub
    3. fix issue LTE Update issue Unable to login/connect to Ubuntu VM · Issue #74 · microsoft/linux-vm-tools doing xrdp connectivity no longer works after apt upgrade in Ubuntu 18.04.1 LTS #76
    4. chose my resolution and shared folders (although shared folders are empty but I’m too tored to fiugre out now why), details are in
      Using Enhanced Mode Ubuntu 18.04 for Hyper-V on Windows 10
  4. Install from the Ubuntu Software Center

    1. VS Code
    2. Node
    3. notepad++
    4. GitKraken
  5. Install yarn

    1. first i tried sudo apt install yarn but was asked to install cmdtest so I got yarn 0.31
    2. followed Installation | Yarn, so 1.22 is installed
  6. installed VS Code React Native Tools


Windows is simpler as you just follow (still downloading)

any concerns?
Otherwise I would follow

git (GitKraken)

this is rather a side theatre of war but as I wasted some hours on it I share it here

If you install GitKraken from the Ubuntu Software Center it installs the snap package what wasn’t listed in in the Software Center anymore so I opend the terminal and did sudo snap remove gitkraken and installed it again.
Next I had to fix GitKraken icon missing - snap -
It turned out that snap package comes with limitations, you cannot use a network share to store the repo on the host to save space or allow to edit it on the host as well, doing only the build in the VM.

so you have to install it like this sudo snap install --devmode gitkraken, see

as that option shown in

is not given.

So far so bad.
After all this I tried several approaches, linking and mounting, fighting with smb shares
see Git clone/pull across local network what is definitely not a good idea.
If you mount it via terminal you fighting with permission, see how-tos

or you use Nautilus and find teh mount as described here

but if you want to clone into this folder, it won’t work as it rename the lockfile
I tried

but none worked.
At the end, I cloned it on the host but opened it in the VM. It worked only when I did a symbolic link to a folder in a shared-drives, what comes with the Enhanced Mode.
But even that is not perfect, as it says all files changed.

May it works if you install GitKaken as app using the standard installer but even when I do this, I get complains, that it is read only, so I think smb network shares between hyper-v and Linux are not perfect