Setting the environment in local system

Hi ,
I am getting difficulty in building the source code in local system . Can you please help me in adding a particular feature and how to how to debug, etc.

Have you read joplin/ at dev · laurent22/joplin · GitHub ?

Hello sir I have read the instructions but I am facing this issue when I run testing the desktop application

Just to make sure, have you tried running yarn install from the root of project as mentioned in the docs?


1 Like

Did you check out the code at all?

Yes I checked, I followed the instructions mentioned in joplin/ at dev · laurent22/joplin · GitHub , But still facing error.

Can you please guide me in setting up the environment

From the above screenshot it seems that you ran yarn init command which is not mentioned in the instructions. So maybe try without running that command.

No sir that doesn't make difference

Did you take a fresh clone after doing that? Just start over.

  • Clone the repo again
  • cd to project root yarn install (it will take a lot longer and have a hell of a lot more steps than in your pic)
  • cd to packages/app-desktop yarn start
1 Like

ok sir I will try and update

You are in the wrong folder, there is no folder named joplin-dev in the codebase

Try this:

  1. Fork the project from the Github homepage.
  2. Clone to your Laptop
git clone<your_github_unsername>/joplin 
  1. Go to the folder where the project is cloned.
cd joplin
  1. from the project root folder run

This will install the packages.

  1. Go to the Desktop Folder.
cd packages/app-desktop
  1. Run the app
yarn start
  1. To see code changes on the app, open another terminal in the app-desktop folder and run:
yarn watch
  1. Re-start the project. (Keep this running)
Ctrl + c

yarn start

Check this for Hot Reload

You are in the wrong folder, there is no folder named joplin-dev in the codebase

I thought this too but the project root name isn't actually important:

PS D:\JoplinDev\test> cd .\joplin-dev\
PS D:\JoplinDev\test\joplin-dev> yarn install
➤ YN0000: ┌ Resolution step
➤ YN0002: │ @aws-sdk/client-s3@npm:3.44.0 doesn't provide @aws-sdk/signature-v4-crt (p6155d), requested by @aws-sdk/middleware-sdk-s3
➤ YN0002: │ @aws-sdk/s3-request-presigner@npm:3.44.0 doesn't provide @aws-sdk/signature-v4-crt (pf5946), requested by @aws-sdk/middleware-sdk-s3

You can see that it happily starts the install in a non "joplin" root dir (providing this "joplin-dev" isn't one step up into the actual root but I doubt this is the case...)

Yes, It will work but Maybe he was not in the correct folder (the actual codebase).

See the Screenshot he provided, it was a new project initiated with yarn init and then yarn install that didn't install any of the Joplin packages.

Then he wouldn't have been able to cd to packages/app-desktop from that location.

Don't know for sure but I'm wondering if the yarn init broke the package.json/yarn.lock hence why I said to get a new fresh clone of the repo

You are right. I just tried using yarn init and it replaces the package.json file with a new one with empty configs.

sir by following the steps above I am receiving this error

Just follow the instructions in the build doc. Use yarn install from the project root.

sir same problem

At least try googling the error:

You were using cmd before which is why you werent seeing PS yarn permission errors, now you have decided to swap to powershell.