Restoring Attachments

On Joplin 2.8.8 on macOS 12.6

On my new computer, I'm attempting to restore a large Joplin note that was exported to Markdown along with pictures that have been saved in a folder labelled _resources.

Scrolling through the .md file on Joplin, I find instances where picture files were previously displayed, are now marked by a file path such as (../_resources/xyz.jpg).

I'm guessing that to restore the pictures so that they display correctly in Joplin, I would need to recreate this folder location and save the attachments to it. Is that correct and what would be the path?

I do not think that will work.

You should be able to import the exported note back into Joplin.

File > Import > MD - Markdown (File)

I just tried it and Joplin imports the pictures and creates new internal links.

Thanks @dpoulton, correct that didn't work.

But, importing the .md file didn't restore the pictures (attachments).

I also tried the Joplin Batch web utility which detected the pictures as 'unused resources' on the note. It gave me the option to Remove/Download each.

Adding each picture manually from the original _resources folder works, but is of course tedious.

To clarify, this is an .md file and _resources folder created in Joplin on one computer and seeking to restore on another computer.

That's odd as it works for me.

Did you keep the exact folder structure as exported? Joplin exports MD with a _resources folder together with a folder named after the notebook the note was in. That folder contains the note itself.

An image reference in the exported note looks like:


where ../_resources/ means "move up one folder and then from there move into the _resources folder". So if the exported folder structure is not maintained the import of the attachments will fail as they cannot be found.


Excellent, that solved it. Simply moved the _resources folder to parent folder of the folder containing the .md file.

Many thanks :+1:t5:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.