Remove old forgotton master key message

Version == Joplin 2.10.9 (prod, darwin)
Operating System == macOS Ventura Version 13.2.1 (22D68

Hi Joplin,

I've been using Joplin for years. So many that I have some old encryption keys that I've forgotten and am unable to upgrade. For years I've had this message at the top of the editor which asks me to upgrade the obsolete key, which I can't do, because I've forgotten it. I understand that I can not decrypt the associated notes. But this persistent message takes up a important space on my screen, and keeps me from enjoying the application.

Is there a way to dismiss this message?


A pasted copy of my encryption config

End-to-end encryption
Encryption: Disabled

Public-private key pair: Generated

Decrypted items: 5499 / 6479

Keys that need upgrading
The following keys use an out-dated encryption algorithm and it is recommended to upgrade them. The upgraded key will still be able to decrypt and encrypt your data as usual.

ID	Upgrade
Master password
Master password:
โœ“ Valid

Hide disabled keys
Active	ID	Date	Password	Valid	Actions
โœ”	e42818XXX13ebae2c8
Source: net.cozic.joplin-desktop	Created: 2020-03-23 11:22 PM
Updated: 2023-03-16 8:46 AM	
Source: net.cozic.joplin-desktop	Created: 2019-05-17 3:45 PM
Updated: 2021-08-24 1:00 PM	
Source: net.cozic.joplin-desktop	Created: 2019-08-14 8:36 AM
Updated: 2021-08-24 1:00 PM	
Source: net.cozic.joplin-desktop	Created: 2020-03-21 8:31 AM
Updated: 2021-08-24 1:00 PM	
Source: net.cozic.joplin-mobile	Created: 2019-05-17 3:52 PM
Updated: 2022-12-21 10:18 AM	

Doesn't it work if you disable the key?

Nope. Message still persists with disabled key.

It wants me to upgrade the disabled key. But I can't, because I don't remember the password for that outdated key.

Ok if it's disabled the message indeed shouldn't show up. I've created an issue there: Don't display "obsolete encryption method" message if the key is disabled ยท Issue #7933 ยท laurent22/joplin ยท GitHub

1 Like

Here's the dialog box when I try to upgrade the key, with the wrong password (don't remember the real one).


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.