Problems when trying to restore a "backup"

First and foremost, I want to be the first one to recognize that the fault is mine. I was experiencing a minor issue with the android app ver 1.0.324 (and I still am. Wherever there is bold text, the app seems to render it in black color even though Im using the oled dark theme, and thus I am not able to read it unless I edit it).
I tried uninstalling the app and deleting the sync target file (I file system as the target) to see if this would resolve the issue. I did back up the file before hand, plus I had previous versions of it, but I didn’t bother to check if this was the proper way to back up your notes.

When I try to restore my notes, it stops when the syncing process encounters the following error:
“Error: On file d541ea4d74ad4d4f9bc3c8d982f8fc80.md: Item cannot be null”. I tried restoring it on windows (ver.1.0.200), same issue:

2020-04-12 17:04:41: “Sync: finished: Synchronisation finished [1586703389590]”
2020-04-12 17:04:41: "Operations completed: "
2020-04-12 17:04:41: “createRemote: 8”
2020-04-12 17:04:41: “deleteRemote: 6”
2020-04-12 17:04:41: “fetchingTotal: 800”
2020-04-12 17:04:41: “fetchingProcessed: 785”
2020-04-12 17:04:41: “createLocal: 784”
2020-04-12 17:04:41: “Total folders: 2”
2020-04-12 17:04:41: “Total notes: 695”
2020-04-12 17:04:41: “Total resources: 6”
2020-04-12 17:04:41: “There was some errors:”
2020-04-12 17:04:41: “Error: On file d541ea4d74ad4d4f9bc3c8d982f8fc80.md: Item cannot be null
Error: On file d541ea4d74ad4d4f9bc3c8d982f8fc80.md: Item cannot be null
at Function.itemClass (C:\Users\username\AppData\Local\Programs\Joplin\resources\app.asar\lib\models\BaseItem.js:96:20)
at Function.unserialize (C:\Users\username\AppData\Local\Programs\Joplin\resources\app.asar\lib\models\BaseItem.js:423:26)
at loadContent (C:\Users\username\AppData\Local\Programs\Joplin\resources\app.asar\lib\synchronizer.js:649:30)
at runMicrotasks ()
at processTicksAndRejections (internal/process/task_queues.js:85:5)
at async Synchronizer.start (C:\Users\username\AppData\Local\Programs\Joplin\resources\app.asar\lib\synchronizer.js:664:20)
at async timeoutCallback (C:\Users\username\AppData\Local\Programs\Joplin\resources\app.asar\lib\registry.js:131:26)”

Depending on how early or late this error occurs, the app is able to restore more or less notes until it comes to a full stop after the error. I think I managed to restore all but one note by making a copy of the file and deleting the faulty md file, that way it doesn’t seem to show any errors.

But another problem persists: all but two of the notebooks are gone. The notes that don’t belong to those two notebooks can be found in the all notes section, but they are no longer classified by notebook. No errors encountered by Joplin this time though:

2020-04-12 18:02:26: "Operations completed: "
2020-04-12 18:02:26: “createRemote: 3”
2020-04-12 18:02:26: “deleteRemote: 6”
2020-04-12 18:02:26: “fetchingTotal: 817”
2020-04-12 18:02:26: “fetchingProcessed: 817”
2020-04-12 18:02:26: “createLocal: 814”
2020-04-12 18:02:26: “Total folders: 2”
2020-04-12 18:02:26: “Total notes: 723”
2020-04-12 18:02:26: “Total resources: 6”

Is there anyway I can fix this and get back my notebooks? I can provide more logs if it would be of help, just tell me what I need to do. I’m sorry for the disturbance, I’m quite old and not very tech-savvy.

You didn’t say what you tried to restore, but did you try deleting the file that cannot be imported?