Home / GitHub Page

Error message when trying to sync in Android

Here’s my problem. I deleted all the data in my synchronization target because I had numerous synchronization passwords and I wanted to remove all of them. Now I’m getting the following error:

Completed: 08/07/2019 10:46
Last error: Error: Error: Directory could not be created. Path: /storage/emulated/0/Shared Notes/Joplin/ .sync

For the directory path, all I did was copy it from a file browser app so I don’t think I fudged it. I tried resetting Joplin by uninstalling/reinstalling the regular way which didn’t work. I then tried uninstalling it with an app called Root App Deleter using its “Silent Uninstall” option and then reinstalling it but that didn’t work either.

I also tried using a root explorer to see if there were any leftover hidden files in my sync target, data/apps, and /storage/emulated/0/Android/data but didn’t find anything uninstalling. Does the app install itself in other locations of Android besides the directory paths I referenced above?

Does anyone have any idea what’s going on here? Thanks in advance for any help.

I think you need to give the app storage permission

That makes sense. The app didn’t prompt me asking for storage permission during installation though.

The error message is gone but now the app isn’t detecting anything in the sync target. It said it synced 8 items but I don’t see anything. There should be way more than 8 items to sync too.

So I tried deleting all the data in the sync target on my PC, hitting the sync button in the PC client, wait for all the notes to disappear, importing them from my saved jex file, then hitting the sync button again. The notes are now showing in the app but they’re still encrypted. In the encryption config, it says, “The master keys with these IDs are used to encrypt some of your items, however the application does not currently have access to them. It is likely they will eventually be downloaded via synchronization.” Is this true? Should I wait? If so, how long?

Alright well I think its working now. My notes are syncing and I can unencrypt them now. I don’t know what I did but I reset the app several more times as well as deleted my config info and notes on my PC. The encryption config still has a list of master keys which ask for my password for each one of them. Wouldn’t just one master key be needed?

You have a list of keys if you generated a new one on different devices.

I have 3 devices but 6 master keys.