Problem with Android 13

Im running a Samsung on Android 13 with April security update syncing to Nextcloud.

I think there could be separate issues here. I cant see how storage permission affects sync as storage permission is applicable when attaching files/pictures to notes.

Re sync make sure you connected Dropbox to Joplin & are pointing the app to your Joplin folder on Dropbox. To sync, the Joplin app has to be open & running in the foreground with the screen on which can take time for the initial sync.

The storage permission is applicable when attaching files/pictures to notes. Grant permision to the "root" area of the device (rather than just the photos folder). Then in future when attaching a file choose from the device location. Example: when attaching a file for the first time select ”Galaxy Tab a8” & grant permission there. When attaching files, navigate through "Galaxy Tab a8" (rather than Recent, Images, Videos, Downloads etc).

If you go to Settings >apps >Joplin >app permissions then remove permission for Music/audio & Photos/videos. Then try to attach a file granting permission as above.

Thank you @bunk3m,

I guess the right place is GitHub - laurent22/joplin: Joplin - an open source note taking and to-do application with synchronisation capabilities for Windows, macOS, Linux, Android and iOS.

Hi @zimmer,
The connection to Dropbox is correct and I am testing with the application open in the foreground the way you say.

I do not have the option to give root access to any application. I think Android normally doesn't allow that, at least on Samsung. Or I don't know how to do it.

I have been using Joplin for several years on my PC (Windows 10) and on my Android phone. I even recently started using it on another PC with Ubuntu. Synchronization via Dropbox always worked and still works fine on all three devices. The problem is only on my new tablet.

I found this on Joplin Github. Maybe it has some relation to my problem.

I am using S3 beta with Tencent Cloud data bucket. Syncing and creating new notes on the PC side is working normally. I am using the latest Android system 13. However, after taking photos or creating new notes on my phone, I am unable to sync the data with my PC. Even though the sync check in settings is normal, an error occurs during syncing with the message "Error: Got metadata for path but could not fetch content:"

I thought the term "root" might not be the best. I meant when attaching files, navigate to Galaxy Tab a3 "parent directory". It just means you can then attach files from within subfolders

I understand, sorry for the misinterpretation. I work in Joplin almost exclusively on my PC. I need access from Android devices mostly to read and, rarely, to edit some text.

I don't use images either, maybe 4 or 5, or attachments. My usage is very simple. That's why I'm surprised by this inconvenience.

I am now testing only with two notes of one word each, nothing more.

Why use "S3 beta with Tencent Cloud" and not just regular S3? since it's beta it's possible it doesn't work properly

Also are you in China? As that could explain the issues with Dropbox as well

Hi @laurent,

The post mentioning S3 Beta is not mine but something I found on Github. I figured it might have some relation to my Android 13 problem. Sorry if that generates some confusion, but it is clarified in the post.

I am in Argentina. As I explained before, I've been using Joplin with Dropbox for years and I have no problems on other devices, only with my new tablet with Android 13.

I really appreciate all the suggestions and time everyone spent on my problem.

Unfortunately, I am going to uninstall Joplin from my tablet for now because I can no longer deal with this.

I hope to try again some other time when I can devote more attention to it.

Thanks again.

Sorry if I missed something, but scrolling through this long thread I don't see any log. We'd need to know that to see exactly what Dropbox error you have and what the fix might be.

As others have mentioned, it's not related to permissions because the only needed permission for this is web access and that's allowed by default. It could also be a particularly large resource that takes a long time to download or to decrypt (if you have encryption enabled)

Thank you.
Please find attached the synchronization report.
I don't know if there is another useful report.
I don't use data encryption. I have 350 notes.

syncReport-1682946685093.txt (48.0 KB)

It doesn't look like there's anything on Dropbox, so maybe the problem is not with Android but with your other device, which is not uploading the data it has.

It's hard to tell exactly what the problem is, but maybe a solution would to use the option to reupload everything from your desktop application. It's under Config => Synchronisation => Advanced options => Re-upload local data to sync target

Then wait for everything to be uploaded. Then uninstall the app on Android, reinstall it, and sync. Normally that should be enough to get the data back

I did what you suggested, but nothing changed. Please note that with my Android 6.0 phone the synchronization works fine.

Also, on the tablet there is a warning message from Android saying that the app (Joplin) is not compatible with the latest version. I don't know if that has any significance.

This is the new report.

syncReport-1682950279192.txt (53.4 KB)

¡Good news! I tried to sync a few more times and now it works.

Evidently it was solved by refreshing the data in Dropbox. Thank you Laurent.


I also had some issues on Android 13 with Dropbox sync.

I created some notebooks, one called "tasks" didn't synchronize on my Android 13 device.
The tasks and notes from this notebook showed at "All notes" tab, but the notebook didn't.

Sometime later, syncing on my computer, it excluded my notebook and I had to recreate, now it's syncing normally.