Pre-release v2.7 is now available (Updated 11 Feb)

No major new feature in this release so far, but many small improvements and bug fixes, as well as new plugin APIs.

If you're a plugin developer, be aware of this change:

Improved: Plugins: Throttle plugins that make too many API calls (#5895)

The goal is to alert you if for some reason your plugin is making more calls than the app can reasonably handle (without running at 100% CPU all the time), and to throttle the API calls when it happens. I don't think any plugin would trigger this at this point, but if you notice anything unusual please post here.

  • New: Plugins: Add support for joplin.workspace.filterEditorContextMenu to allow dynamically setting editor menu items depending on context (960863f)
  • New: Plugins: Add utility functions and (27b62bf)
  • New: Plugins: Added "openItem" command (83c0c48)
  • New: Plugins: Added ModelType type (c423551)
  • New: Plugins: Added revealResourceFile command (6e6432b)
  • New: Plugins: Adds joplin.workspace.onResourceChange (2660ff3)
  • Improved: Adjusted styling to make it more consistent across app (d031a04)
  • Improved: Better handling of bold text to simplify customisation (#5732 by Hieu-Thi Luong)
  • Improved: Clickable tags in Tag Bar (#5956 by Kenichi Kobayashi)
  • Improved: Do no duplicate resources when duplicating a note (721d008)
  • Improved: Expand search field when clicking on search button (#5893)
  • Improved: Focus notebook title when opening Notebook dialog (3117133)
  • Improved: Plugins: Throttle plugins that make too many API calls (#5895)
  • Improved: Prevent Desktop Environments to launch a new window (#5984 by Felipe Kinoshita)
  • Improved: Right click on image to copy it to clipboard (297b992)
  • Improved: Show login prompt for OneDrive (#5933 by Jonathan Heard)
  • Improved: Use same notebook dialog when creating a new notebook too (#5934)
  • Fixed: Add back text editor commands to Command Palette (#5707)
  • Fixed: Cannot jump if local search count is one (#5894) (#5549 by Kenichi Kobayashi)
  • Fixed: Editor loses cursor focus when Ctrl+F search is closed (#5919) (#5850 by Kenichi Kobayashi)
  • Fixed: Fix white space in the bottom of Add Tag Prompt dialog (#5998 by Krishna Kumar)
  • Fixed: Fix wording "Check for updates" in settings (#5832 by Helmut K. C. Tessarek)
  • Fixed: Fixed issue where synchroniser would try to update a shared folder that is not longer accessible (667d642)
  • Fixed: Fixed order of editor search buttons (6bc70ed)
  • Fixed: Fixed search icon when note list is resized (#5974) (#5916 by Krishna Kumar)
  • Fixed: Note list buttons do not reappear after changing app layout (#5994) (#5953 by @asrient)
  • Fixed: Scroll jump when checkbox is toggled in Viewer (#5941) (#5890 by Kenichi Kobayashi)
  • Fixed: Scroll jumps when images are rendered in Markdown Editor (#5929) (#5918 by Kenichi Kobayashi)
  • Fixed: Scrolling was out of sync when a Multi Markdown Table was being used (#5815) (#5808 by Caleb John)
  • Fixed: Show error on sync if S3 region is not set (#5923) (#5875 by @shinglyu)
  • Fixed: Update menu item labels when the language changes (#5927)
  • Security: Fixes #6004: Prevent XSS in Goto Anything (#6004)


Error after upgrading to 2.7.5 on Windows 10 Pro Desktop, Version 21H2 Build 19044.1466.

  • This is a setup-based installation for local user.


Reverted to 2.6.10.

Thanks for the report. I've took out the pre-release for now (although it works at least on macOS, maybe Linux too).

prod, linux 2.7.5
Kubuntu 21.04

Graph plugin cannot load the full graph anymore. It does load the UI (buttons and knobs) but the graph is not showing up even after 30+ minutes. Reloading the graph results in UI no longer showing up.

It does work on 2.6.10 with the same environment.

I suppose it is expected behaviour though as the plugin is heavy on its calls.

Curious if the behaviour could be reproduced in the other environment.

Merci. If I can help troubleshoot, let me know.

I got the same error that bladewolf55 got, even with all plugins disabled. I'm on Windows 10 Home Version 21H2 Build 19044.1499 (preview release).

All seems good here.

Joplin 2.7.5 (prod, linux)

Ok, sixth attempt - please let me know if it's any better on Windows:


Works now! Tested on Win10 and Win7. Many thanks!


Maybe the Plugin throttling, should be reverted for now? Because some plugins like Note Link System and Note Overview are kinda unusable with this change

This is a pre-release, which is exactly for such a thing there, so that at the program itself or also plugin developers can adjust something if errors occur.


Surely the entire purpose of a pre-release is so the settings can be tweaked on both the plugin and application side? If you need the plugins then revert to a release version.


As a user of a low powered device, I, on other hand, don't mind the throttling, but I would definitely appreciate some sort of battery saving controls/throttle modes or plugin status showing what plugin is being throttled.

I feel a lot of plugins gotta be load tested with the new feature. So far, I've only got to load Attache, Graph and Backup plugin with the medium size database. Graph plugin couldn't load well as described above but the rest are fine :relieved:

Thanks for the feedback, and please keep reporting plugins that don't work well due to this throttling feature.

I've tried to set it up so that it only affects plugins that could be considered faulty - for example if the developer forgot a timer somewhere that's constantly making API calls, or if the plugin doesn't wait for the API response before making a new call.

I'll check these plugins and see if it's an actual issue with the plugin, or if I need to tweak the throttling mechanism.

I think that perhaps the API calls would also need to be adjusted so that API calls can handle requests for multiple notes instead of having to make a request for each note.

That's true, some kind of batch API maybe. Also perhaps we could increase the number of items that can be retrieved in one call.

1 Like

I just saw the improvement that tags in the tag bar are now clickable. That's great!! Long awaited feature.

Thanks to the whole team!


2.7.6 and 2.7.7 both seem to be working fine so far. Thanks for the quick fix, Laurent.

2.7.8 is available:

  • Improved: Disable plugin throttling for now (6bb0318)
  • Fixed #6035: Revert "Desktop: Fixes #5850: Editor loses cursor focus when Ctrl+F search is closed (#5919)"

1 Like

This isn't a great bug report since I can't reliably repro, but I have noticed since I upgraded that the Note Tabs plugin sometimes becomes unresponsive and I have to quit the app to get it to change notes. Putting this out there in case someone else notices it, and I will keep trying to repro / see if there is an error in dev console. cc/ @benji300