Plugin grayed out: "Please upgrade Joplin to use this plugin" while running latest Joplin version

Operating system

macOS

Joplin version

2.14.22

Desktop version info

Joplin 2.14.22 (prod, darwin)

What issue do you have?

I want to install the Note list (Preview) plugin in the Plugin setting page. When I search for it, it appears but is greyed out, with the above message being displayed. I've just installed the latest version from the Joplin website.

I succeeded to install it doing a "Install from file" install. It now appears in my Plugins list, but it's still not working, still grayed out with the same message.

My computer is a Macbook M2. On the Joblin download page, one can download a MacOS or a MacOS M1 version. I've tried both to no avail.

Help? :slight_smile:

Screenshots

When installing the plugin for the first time, Joplin only checks whether the latest version of the plugin is compatible with the installed Joplin version.

However, the latest version of the plugin requires a Joplin version 3, which is still pre-release. this is why this message appears. The version 0.4.2 (last working version with Joplin Version 2) of the plugin can be installed manually, see description in the documentation:

Thanks heaps Jack. Following your link, I've downloaded and installed the 0.4.2 version manually but it still shows in the Plugins page as grayed out in the same way. I have restarted the app. Maybe I need to remove the previous plugin for it to work? I'm looking at the /help/apps/plugins page and I don't understand how to get to my ~/.config/joplin-desktop/plugins mac folder.

Ok, found my Profile directory and the plugins folder.

  • I shut down Joplin
  • removed the previous io.github.jackgruber.notelistpreview.jpl plugin
  • restarted Joplin
  • Shut down Joplin
  • moved the 0.4.2 version in the folder
  • restarted Joplin

It's still grayed out...
I've also tried doing the above with doing the manual plugin install with no success.

Damn.

This is OK, because the Update to the newer version is not supported on a version smaller than Joplin 3.0.3!

Ok, I didn't fully understand why the 0.4.2 version didn't work with Joplin 2.14.22 but I've installed version 3.08 and it's working now so that's good :slight_smile: