Note export to PDF, hyperlinks inactive

Really liking tis app, thanks big time!
Tried the web clipper in Firefox and grabbed a page with a host of links and pictures - it grabbed it all. pretty slick. However, when exporting to PDF the pictures and underlined hyperlinks were present, but the links were not active.

Are there plans to make active links port over to PDF or am I missing a step?

No, it should work out of the box. Can click on a link in your clipped note in the preview pane (the right one)? If yes, it should also work after exporting it to PDF. If not, there might be an issue with the clipper.

Can confirm. I can click on the link in the preview pane, but after exporting to PDF the link is no longer active (though still blue and underlined as if it were a hyperlink).

Does this happen with all notes, or only with the clipped ones?

Hi. I hover my mouse over the hyperlink in Joplin’s display window of the note, a bubble appears of the web page. If I right click on the note to export to PDF, the hyperlinks “appear” with underline/blue font, but will not launch a web page.

I created the markdown page using both the Firefox and Chrome web clippers. Seem to work in Joplin in either case, but it’s after the export to PDF where it stops.

Happens if I create a hyperlink manually in Joplin. New Note, created a link to, export to Macos Mojave desktop…Use either Preview or Books to view the PDF - same results with hyperlink present without activity from clicking on where the hyperlink is.

Huh. When I sent the PDF created by Joplin to my iPhone, it worked once from the app it imported to, Documents 6, but stopped working after the one time it opened a page from a web link. Strange.

No, it seems that inline links [text](link) are not correctly exported.

There was a github issue a while back:

which was fixed by this commit:

@laurent any chance this fix got lost during the rewrite of the rendering code?

Normally the same code was used but I’ve reopened the issue just in case.

I was able to reproduce this issue. Inline links are no longer clickable after export to PDF.

Signed up just to mention this. I thought the issue was closed with no upstream (electron) fix. But when i recently tried another electron based note app and copy-pasted my Joplin MD into it, including inline links, they exported to PDF as clickable hypertext.

Absolutely love Joplin, and how it has super functional and organised interface. Thanks for all the great work.

edit: What i have just noticed is that URLs, plainly typed, ie, will be exported as clickable hypertext.


I’m a new Joplin user, and I LOVE it. But today, I tried to export the note as a pdf, all links (to a web or the toc) are inactive. I also saw that the problem has been closed in Apr 2019 and it seem has been solved. I’m using v1.0.233 which is realsed in Aug 2020 on WIN10. I don’t know why it doesn’t work.

That happened last year. Bummer.

@laurent it seems that the refactoring messed this up again.

I can’t replicate in the latest version. For example the links in this note when exported to PDF work:


or if you have a problem with a specific note, please post the markdown.

Sorry, I was merely commenting to yw3a14's comments that the links were broken in PDF, I recalled it happened last year. I responded from my mobile device, I hadn't tested their statement was in fact happening again, just interacting a time frame it happened.