Note editor appearance

Hello everyone!

I am using Joplin 2.7.13 (the latest version) on a laptop running Windows 10 Home, and I have a problem with the note editor (markdown).

I haven't used Joplin in a while, but I remember the note editor being in coloured monospace font. Now it looks the same as the font in the viewer panel.

I am really sorry for asking such a noob question, but I've been trying to solve the problem myself for the past few hours (playing with the appearance settings) and I've searched online for the answer, but I didn't find the answer I was looking for.

Thank you in advance!

Have a look at this post - should have everything you need.
The styling was changed quite a few versions back now.

1 Like

Thank you very much!

I've changed the files according to this post, quit the app, started it again, but nothing has changed.

If you are on Windows make sure you have fully quit the app and not just minimised it to the systray.
If you have definitely done that then can you post the contents of your userchrome.css file here (put it in a code fence by surrounding in triple backticks (```))

Thank you for the replies!
I've made sure to properly quit the app. Here are the conents of my userchrome.css: {color: #dddddd;} {color: #d44;} {color: #292;}, {font-weight: bold;} {font-style: italic;} {text-decoration: underline;} {text-decoration: line-through;} {color: #c792ea;} {color: #f78c6c;} {color: #ff5370;} {color: #00f;},,, {} {color: #eeffff;}, {color: #decb6b;} {color: #878787;} {color: #c3e88d;} {color: #f50;} {color: #ffcb6b;} {color: #decb6b;} {color: #555;} {color: #30a;} {color: #ff5370;} {color: #ff5370;} {color: #00c;} {color: #dddddd;} {color: #c3e88d;} {color: #dddddd;} {color: #89ddff;} {color: #dddddd;} {color: #f00;}```

That one works fine for me. Are you using the right theme for it? (i.e. to use that one you need to be using the dark theme, for the light theme you need to use a different set).

Yes, I am using the dark theme. I think I give up.

The userchrome.css css above should change colours and some styling, however setting the editor to use a monospace font again is done using Appearance in the settings menu. Just enter the name of a monospace font installed on your system.


Thank you for the reply! I've already done that and consider it a good enough compromise.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.