No play back sound in a video embedded in a markdown note

Joplin 2.7.15
osx Monterey 12.3

Dropped a 1 gb training video in a markdown note.

Video plays back but I do not hear any sound.
Is this a permission thing?
How do I fix it?
Thank you.

What format is it?


Do you find any error related to this in the console (Help -> Toggle Development Tools)?

I don't see any errors in the console output other than this one loading the DevTools:
DevTools failed to load source map: Could not parse content for file:///Applications/ Unexpected end of JSON input

Thats pretty normal so not the issue you are seeing.
I had a go at throwing a tiny generic mp4 file into Joplin on macOS and the sound worked just fine so it isn't the mp4 file type itself.
I downloaded the first file on this page to test (as it is tiny) -
Might be worth seeing if you can replicate it with this video.

Yes the first video works for me too in a new note.
The differences in the video are
size: 10.5 meg vs 1gb
340x240 vs 1920 x 1055

My video was a screen recording made with snagIt.

I did try it again with a file that was only a couple meg in size and much shorter record time and I was able to hear the sound.
Dropped the large file again into the new note and no sound still.
not sure what else is different between the files other than size because I used the same tool to capture the screen and audio for them.

Is the sound working in e.g. VLC? If yes, what Audio Codec is the video using (in VLC Ctrl+J)? For me a 1.1 GiB Video 1920x1080, AAC Audio is playing fine in Joplin...2.8.4 though

What is really odd is it won't play audio in VLC either. But the small video will.
Both video play in osx native video player.

The video codec info is very similar.
Only difference is video resolution / buffer dimensions 1920x1055 vs 1920x887 with buffer 1920x896.

I also tried dropping a .mov video into a note and it will not play at all.

-- Sorry audio were both MPEG AAC (mp4a)

Okay then the problem is definitely the video, I would say...but to be honest, I don't really know any further than that...

.mov should be supported too as of this page (Joplin is based on Electron which is based on Chromium), but on my end it is not working either...

Ok thanks for your help.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.