No more launching appImage applications at startup after update 24.04

Operating system

Linux

Joplin version

3.0.8

Desktop version info

Version de Synchro : 3
Version du profil : 47
Trousseau supporté : Non

Révision : 826006c

Backup: 1.4.1
Favorites: 1.3.2
Note list (Preview): 1.0.0

What issue do you have?

Hello
1/ Since the update, I no longer have the launch of certain applications (Joplin, Ferduim) for which I put the command in "Applications at startup"

~$ sh -c 'sleep 2 && "/media/rv/data/Comp.com./Appli-data-port/Joplin/Joplin.AppImage"'
Setting $HOME to /media/rv/data/Com. computer/Appli-data-port/Joplin/Joplin.AppImage.home
[14056:0528/085134.690028:FATAL:setuid_sandbox_host.cc(158)] The SUID sandbox helper binary was found, but is not configured correctly. Rather than run without sandboxing I'm aborting now. You need to make sure that /tmp/.mount_JoplinTlXjEW/chrome-sandbox is owned by root and has mode 4755.
Trace/breakpoint trap (core dumped)

2/ Is the directory naming correct?

I'm linking to a related GitHub issue:

1/ Thank you for the quick reply. If I understand correctly there will be no quick resolution unless you put --no-sandbox (only solution for a non-developer but which would not be very secure?)

2/ Is the directory/file naming correct?

Hi
I see the previous message again. I'm using the new version 3.0.8, does this change anything?

Another suggestion: to have an option to launch Joplin automatically at startup!

Should I post this on github?

There's no (likely) scenario the requirement is dropped without either a native package installation or passing --no-sandbox, which the installation script should set up automatically.

The current official installation process is entirely unprivileged and can neither turn the security restrictions off nor grant itself an exception to them.

There's no required structure so yes. Your structure is effectively just the default but with the AppImage native functionality to rewrite $HOME implicitly.

It'd be nice if the app did this itself but as a workaround you should be able to add Joplin by path to the DE's startup list. This one again isn't actually too hard to get going but has complexities with the installation being an AppImage (I.E it's expected that integration is handled by the script, but not everyone will install with the script; some people will make their own autostart files, etc.)

ok thanks I'll wait. in the meantime I'll launch it manually

If you were happy to disable the security settings entirely, you could run

sudo sysctl -w kernel.apparmor_restrict_unprivileged_unconfined=0
sudo sysctl -w kernel.apparmor_restrict_unprivileged_userns=0

This would let the AppImage work via double clicking and allow Electron to use its usual sandbox. If you've a lot of electron appimages it could be worth considering.

Hello
Thanks but I don't prefer to bypass security.
Eventually even if it's not very good, I understood that I could use ./Joplin.AppImage --no-sandbox while waiting for this problem to be taken into account

HI
For information, I can launch it in the terminal with the command
./Joplin.AppImage --no-sandbox
but not with
sh -c "/media/rvnux/donnees/Com.\ informat./Appli-donnees-port/Joplin/Joplin.AppImage --no-sandbox"

Hi
it works with
bash -c 'sleep 3 && /media/rv/donnees/Com.\ informat./Appli-donnees-port/Joplin/Joplin.AppImage --no-sandbox'