Mobile and Desktop app aren't in perfect sync

First of all:
I’m already using Joplin for the last 2 years and this is the first time I had any problem.

I already read all the documentation in the website, similar issues in github, already read all similar support request in this forum, already tried a lot of things in mobile and desktop apps, but nothing solved my problem. So, let’s go:

If I create a new note in the desktop app, it will normally appear in the mobile. So, It’s syncing. BUT not perfect: some movements of subnotebooks in the desktop did not appear in the mobile. Same as some new subnotebooks. It seems as some notebooks are frozen in mobile, and don’t reflect the last changes in desktop app.

  • Version in Desktop app: (Ubuntu 18)
    Joplin for Desktop
    Copyright © 2016-2018 Laurent Cozic
    Joplin 1.0.105 (prod, linux)

  • Version in Mobile: (Android Samsung Galaxy S8): Joplin 1.0.316

Sync method: Dropbox (I never changed NOTHING manually inside the “Joplin” directory of my Dropbox)

The current status of syncing:
Sync status (synced items / total items)

Note: 1562/1468
Folder: 68/62
Resource: 935/908
Tag: 0/0
NoteTag: 0/0
MasterKey: 0/0
Total: 2565/2438

Conflicted: 0
To delete: 115

Please I love Joplin. I would pay for use this service, as I used to pay for Evernote
I discovered Joplin when I moved from Windows 10 to Ubuntu 18, 2 years ago, and actually fell in love with Joplin because I can use Latex, Katex Equations, Markdown, Dropbox sync, and so forth.

This is a very hard problem to solve unfortunately, my best guess is that your computer or phone is not time stamping files correctly. Have you recently changed drives are anything like that? I believe that some filesystems don't have accurate time stamps, which Joplin depends on for sync. If this is your problem you'll likely need to solve it on your end by changing filesystems.

With that said, I used to experience the same problem as you (some files would stop syncing at random) a short term solution is to force those files all files to resync by opening a terminal at your Joplin sync location and running touch *

I haven't experienced this issue in a long time and I believe that's because of updates and fixes that have happened in the last year. My recommendation is for you to update your desktop and mobile apps to the most recent versions available. You'll also be able to enjoy all the other features and improvements as well :slight_smile:

And by the way, if you're interested in supporting Joplin you can find donation links on the homepage.


Thanks for the reply John.
Today I’m worked harder to understand the way the notes, notebooks and notebook hierarchy are stored inside my “Joplin Dropbox directory”.

And I made a lot of tests creating notes and notebooks in the mobile and desktop. What I discovered:

  • When I create a new mobile note and notebook, a new register appear in the Dropbox (after sync of course). So, Mobile looks, working fine. But Desktop are NOT opening this new notes and notebooks even after I force a new sync in desktop. (The new md files ARE in the dropbox directory in desktop, and I also can normally open them with other applications)

  • When I create a new note in desktop, it creates a new register in the dropbox, and IF the notebook exists in mobile, It will appear. However, if I create a new notebook, it creates a new register in dropbox BUT id does not show in mobile.

Both applications are their latest versions with 100% sure.

It’s hard to tell if I updated some drive recently because I always do the updates that Ubuntu 18 ask me to do (although they aren’t mandatory).

What I DO know is that I used joplin during 2 years without see this happening.

After these 2 years using it, I’m very happy to make my first generous donation to the project once someone of the team help me to overcome this issue and continous to use Joplin to make all the annotations of my life.

Can you guys help me?

Best Regards,

I’m not sure if this helps but when I synced with Dropbox I did set Joplin (on Ubuntu) with Synchronisation target = “File system” instead of “Dropbox”.

In “Directory to synchronise with (absolute path)” I entered the path to my Dropbox\Apps\Joplin folder on the Ubuntu machine.

Worked much better on Linux than the “Dropbox API”.

I would take care and be sure to have a backup first before testing…

Thanks eagle, I will try it. Let’s see what will happen

Thanks for the suggestion, but I tried here and It didn't work. :frowning:

Hey guys, if anyone have know-how to solve this problem I can pay for the “assistance service” 36 USD, which is less or more equivallent of a anuary fee of a SaaS subscription of a service of this level.

If anyone candidates, please, let me know.

Hello John, supposing this is really a timestamp issue, do you know how I can solve it?

I could pay for service assistance, as I said in another comment.

I’m happy to keep helping you to the best I can, no payment necessary.

How are you updating Joplin? You say that you’re confident that you’re on the latest version, but the latest versions are
Desktop: 1.0.179
Mobile 1.0.136
CLI: 1.0.153

So it seems to me that you’re on a very out of date version on desktop.
You can find the current releases on GitHub

On Linux it is recommended to use the update script, via a command, I’ll copy it below.
wget -O - | bash

1 Like

Thanks CalebJohn.

I only use mobile (android) and desktop (Ubuntu 18).

Mobile is OK: 1.0.316
Desktop: That’s the question: I already used the recommended script: wget -O - | bash

and it says:
bla bla bla…

Linux Installer and Updater
You already have the latest version
BUT, when I go inside the Joplin desktop app and go to “help > about joplin”

Joplin for Desktop

Copyright © 2016-2018 Laurent Cozic
Joplin 1.0.105 (prod, linux)

So… I’m not sure WHAT version of desktop app I’m using, but I think It’s just the “about joplin” inside the app that is outdated, but not the version itself.

How can I check the version of Joplin?

It looks like you accidentally have 2 versions of Joplin installed in your system and you’ve been loading the old one.

try running this command from your home directory


Before doing this I recommend that you backup your notes, You can do this by exporting to a jex file using File -> Export -> Jex

1 Like

Thank you so much @CalebJohn, you really solved my problem! I was with an old version.

And I didn’t know that I was using an old version. Wow! The new version is by far better! (with obvious exception of the electron initialization bug).

After 2 years using Joplin, this episode made me remember that I never contributed before. So, I already became a patreon from Joplin in!

I want to donate more, a non-recurrent donation of 72 USD, which is less or more equivalent of a monthly subscription of Evernote Premium for the past 2 years that I never donated. But for this, I think It’s wisdom to wait the bug that enforce us to start by terminal de desktop app.

Best regards