Missing Icons In Toolbar

Operating system

macOS

Joplin version

2.14.20

Desktop version info

Joplin 2.14.20 (prod, darwin)

Client ID: 06bfa01009a643409784ddf44629b812
Sync Version: 3
Profile Version: 46
Keychain Supported: Yes

Revision: cfd98e3

Backup: 1.4.0
macOS theme: 1.3.5

Editor

Markdown Editor

What issue do you have?

Good day,

I didn't really want to create an account, but for the last several versions, there have been missing toolbar icons in the MacOS desktop version. I had hoped people would notice and correct this, but after several updates and the issue persisting, I decided to come here and make you aware of it - if you aren't yet already aware. I have included a screenshot that shows my toolbar, and further to the right you can see the missing icons, although still separated by the vertical lines for spacing.

It isn't a huge deal, as I only really use the last one on the far right which is the one for the timestamp, but it would be nice to see the full toolbar icons once more.

Thank you kindly for this wonderful software that gifts privacy for everyone. :heart::person_in_lotus_position:t2:

Screenshots

Can you check what happens with the custom theme disabled?

There is no custom theme. It is just the dark mode built into the app. This was fine last year, but after an update it just went to this.

The theme is still listed as installed, so there's a chance that it's causing conflicts. Can you post a screenshot of what you see in Tools → Options → Plugins? If the theme is listed there, please try to uninstall it completely, then restart Joplin and see what happens.