Max Attachment Size when Syncing?

Is there a max attachment size when syncing and is it changeable? I'm using Joplin 2.9.17 on Windows 10 and syncing to a Joplin server (2.10.11) on a raspberry pi and I'm getting the error:

Uploading items larger than 250 MB is currently disabled

Is this a Joplin issue or maybe a server issue? The file in question is ~200 MB (after encryption ~330 MB; it is a zipped binary) and I can foresee adding other larger files, so I would prefer to do this without having to split the files or anything similar.

If you log-in to your Joplin Server as Admin there is an option for Max Item Size (in bytes) under the settings for each user account. Do you have anything set here?

Sigh. I could have sworn that I looked at this screen. Both of the fields there were blank and they were showing up as infinite in the users screen.
I made the max item size 1/2GB (which should be plenty) and tried syncing again, but I'm getting the same error. Any thoughts?

Are you accessing the server through a reverse proxy? Could it be the webserver that is applying a limit? In nginx I believe that the setting for size is client_max_body_size. To be clear, I am just making guesses until someone knowledgeable turns up!

I found this on GitHub in the code for the server


itemSizeHardLimit: 250000000, // Beyond this the Postgres driver will crash the app


if (itemSize > this.itemSizeHardLimit) throw new ErrorPayloadTooLarge(`Uploading items larger than ${prettyBytes(this.itemSizeHardLimit)} is currently disabled`);

So it looks like the server actually has a 250MB hard limit to prevent the Postgres driver crashing the server.

1 Like

Well, it is good to know the issue. I will just deal with a workaround. Thanks for the help.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.