Homepage    |    GitHub    |    API    |    FAQ

Manually disable WYSIWYG editor?

WYSIWYG editor is a good addition to Joplin, yet I am mostly using the raw editor. As the editor mode change (between raw editor and WYSIWYG editor) might cause certain markdown styles to be lost, I am wondering is there any switch or setting that I can toggle to disable WYSIWYG globally (or for certain notebook).

OS: Windows 10
Joplin Version: 2.3.5 (prod, win32)

I removed the selection button with CSS.

This seems to be a solution. Can you share the related CSS code you used?

Sure:

1 Like

Thanks! That worked flawlessly.

As a side note, here are the steps to apply that style:

  • Settings / Appearance
  • Show Advanced Settings
  • Custom stylesheet for Joplin-wide app styles
  • Paste the CSS code into the editor
  • Restart Joplin Completely (from tray)

And here is the result:

Does this mean that there is no way in the interface to actually disable the functionality?

I am not sure I follow. There's the button in the interface that allows you to switch between the markdown and the wysiwyg editor.

I removed the button via css, so that I don't accidentally click it.

There's no setting to remove that button.

Sorry. I've been getting some odd behaviour when using the command palette where I think(thought? still not sure) that I am being sent to the WYSIWYG editor. That's why I was looking for something stronger than disabling CSS. But I just need to figure out what is causing my real problem. Thanks!