Home / GitHub Page

Make .resources non-hidden for FileSystem Synch

I am running version 1.0.201 on a Mac Mojave and 1.0.201 on Windows 10.

I have set up File System for synchronization, giving the path of a folder on the desktop of both machines.
That folder gets synced to a Synology NAS as soon as a file is saved on it, so it’s basically a shared folder over the network.

Notes synch flawlessly, they never leave my network and I have a backup of everything in case of disaster. I am very happy about that setup.

The problem comes to the attachments.
The note will show attachments only on the machine they were added.

Example: I create a note on the PC, add a picture, synch. Open it on the Mac after synch, add another picture, synch.
Mac will render only the picture that I added on the MAC.
PC will render the picture added on the PC.
Both show the full note content with the links to both images.

I did some debugging and found out that Joplin correctly stores the attachments on the .resource folder rather than the .config/joplin-desktop
The problem comes as Synology will not synch hidden folders.

I tried to make that folder visible, but Joplin automatically creates again the hidden folder and ignores the non-hidden folder.

Is there a way to force Joplin to work with a non-hidden folder to handle the attachments on the FileSystem synch?
I mean, if the notes are visible, I don’t see the issue with having the resources visible too.
But I can’t find any option regarding resource location.

Thanks!

The PC uses the file system to synchronize to the A folder, the cloud synchronizes the A folder just fine, do not directly synchronize the configuration folder

I am not synchronizing the configuration folder.

Let’s say I created a folder on the desktop called JanisSynch.
I add the path to that folder on the File System synch.
I add that folder to the Synology Synch.

The notes are visibly stored there and they sync nicely, but the resources are stores in a hidden folder there JanisSynch/.resource and they won’t’ synch.

I’d like to have that JanisSynch/resource instead, making that folder visible.

Not hidden

My Synology Backup / Sync client has an option to include files / folders prefixed with a .

Many thanks dpoulton, I totally missed that. The sync task was created a long time ago (just pointed the Joplin sync path to a folder inside the SyncDrive).

All working now.