Lost all notes, anyway to recover from Joplin Server?

  • The version you are using. LATEST VERSION is not a version number!
    Joplin 2.6.10 (prod, linux)

Client ID: bcd706bf476240bf8d35352e6aaca494
Sync Version: 3
Profile Version: 41
Keychain Supported: No

Revision: 98fba37

  • If it is a sync issue, please let us know what you are syncing with.
    Joplin Server in Docker on UnRaid

  • The operating system you are using.

I was trying to decrypt my notes after reloading the OS and I was having difficulty remembering the password. I finally remembered after 10+ tries at getting it, and when it went to decrypt, it pulled down nothing, but says there are 23 items to decrypt. I tried syncing again, no change. I closed the app, reopened it, and still no change.

I then asked it to decrypt and still nothing. Now when I look at the server dashboard, it says that user has 19Kb of info and I know that can't be right. I haven't done any sort of backups on the postgresql DB, I haven't looked to see if there is a way to restore Docker container info or anything, but are all of the notes hosed?

I don't have a client that has a clean copy of the notes at this point, and I'm concerned about the other user I have for work notes.

Edit: Because I used Postgresql 14, it has some WAL files in the directory, so I may be able to do a playback of that, and not lose anything since I haven't added or changed anything with any of my users. I'll investigate that route, but if anyone else has any suggestions I'm open to them.

Also before anyone asks, I did have an export file but it was mistakenly nuked when I did my initial backup, and that's on me to have done a better job of taking care of it.

How'd you do it?

I actually wasn't able to restore from anything because the DB system itself doesn't create a full backup it seems. That said, the items are there, but I can't see them, so it might be possible to hand dig into the DB and make the records visible, but I have no idea how to do that, and since the data is encrypted I'm going to presume it's lost forever and will need to reconstruct what I can :frowning:

That is assuming no one has any suggestions on how to recover it some other way.

Everything's in the items table, in the content column. But you'd need to write a program to read each row and write it to file. Then you can use the cli tool to decrypt the files. It's quite a bit of work so it depends how much you want to recover the data.

Well, I got lucky-ish. I still have the original notebook files I used to convert over to Joplin, and that's about a month behind, but most of my notes were converting hard copy and taking down info I can easily get back, so it's not the end of the world there.

I'm still not sure what triggered it to nuke all of the user's data though, so if anyone has any insight on that I'd appreciate it.

So the lesson here is: If your DB is taking backups properly, you can roll back transactions within it and recover your data.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.