Joplin Windows Client semi-frozen after note upload

I’ve been using rest_uploader as a way to make all the PDFs in my notebooks searchable. The workflow is that I drop a PDF into a folder that is watched by rest_uploader, then it OCRs it and creates a note in Joplin. I’ve been using it for a month or two now and done hundreds of PDFs, but yesterday when I tried to do it again, it/Joplin choked.

Now Joplin will open up, but it’s semi-frozen. I can click on menu items (though nothing happens) and can scroll through my notes and tags (though it doesn’t show what is below the fold when I scroll… just blank space).

I tried to delete the files that were created when the break happened (located in C:\Users\user\.config\joplin-desktop. But that didn’t work.

I then reinstalled Joplin, which also had no effect.

in logs-database.txt there is a change in pattern around the time of the offending note (~3:15pm)

2019-10-30 15:11:11: “Settings have been saved.”
2019-10-30 15:12:10: “Saving settings…”
2019-10-30 15:12:11: “Settings have been saved.”
2019-10-30 15:12:43: “Saving settings…”
2019-10-30 15:12:43: “Settings have been saved.”
2019-10-30 15:13:02: “Saving settings…”
2019-10-30 15:13:02: “Settings have been saved.”
2019-10-30 15:14:11: “Saving settings…”
2019-10-30 15:14:11: “Settings have been saved.”
2019-10-30 15:27:28: “Database was open successfully”
2019-10-30 15:27:28: “Checking for database schema update…”
2019-10-30 15:27:28: “Current database version”, “24”
2019-10-30 21:24:23: “Saving settings…”
2019-10-30 21:24:35: “Database was open successfully”
2019-10-30 21:24:35: “Checking for database schema update…”
2019-10-30 21:24:35: “Current database version”, “24”
2019-10-30 21:24:38: “Saving settings…”

Also here are the logs from log.txt

2019-10-30 15:12:47: "Operations completed: "
2019-10-30 15:12:47: “createRemote: 1”
2019-10-30 15:12:47: “Total folders: 13”
2019-10-30 15:12:47: “Total notes: 5101”
2019-10-30 15:12:47: “Total resources: 15986”
2019-10-30 15:14:10: “RevisionService::maintenance: Starting…”
2019-10-30 15:14:10: “RevisionService::maintenance: Service is enabled”
2019-10-30 15:14:11: “RevisionService::collectRevisions: Created revisions for 2 notes”
2019-10-30 15:14:11: “RevisionService::maintenance: Done in 240ms”
2019-10-30 15:15:54: “Scheduling sync operation…”
2019-10-30 15:15:54: “Scheduling sync operation…”
2019-10-30 15:27:28: “Profile directory: C:\Users\user/.config/joplin-desktop”
2019-10-30 15:27:28: “Trying to load 1 master keys…”
2019-10-30 15:27:28: “Loaded master keys: 1”
2019-10-30 15:27:28: “ResourceFetcher: Auto-add resources: Mode: always”
2019-10-30 15:27:28: “ResourceFetcher: Auto-added resources: 0”
2019-10-30 15:27:28: “Trying to load 1 master keys…”
2019-10-30 15:27:28: “Loaded master keys: 1”
2019-10-30 15:27:28: “Scheduling sync operation…”
2019-10-30 15:27:28: “Trying to load 1 master keys…”

Any suggestions on what I should try?

Version: 1.0.170
OS: Windows 10

Is there anything in the console? https://joplinapp.org/debugging

No, nothing in it.

Here’s a quick screencap of what I’m seeing (with the console in it… you can see nothing pops up)

I think it might be something wrong with the note that’s displayed by default. What if you select another note, or even an empty note? Do you still have the same problem?

Thanks for being so responsive btw :slight_smile:

Can't select any notes, new or empty

Only things I can select are the menu items (File/Edit/View/Tools/Help), that opens up the submenu, but upon clicking on an entry (e.g. GoTo Anything), nothing happens.

Ok, came up with a solution.

I used sqlitebrowser to open up "C:\Users\user\.config\joplin-desktop\database.sqlite" and deleted the offending entry from both the notes and resources databases.

Thanks for the help!

You don’t have happen to have kept a copy of the offending note and resources? It would be very helpful to replicate and fix this bug.

I don’t have the note, but I’ve attached the resources.

The note was created automatically by dragging this into a folder being watched by rest_uploader

b83825df23af44038f66d578b5fc759e.pdf (1.9 MB)

Thanks i will give it a try.