Joplin Web Clipper not downloading images due to SSL error

Hello everyone,
I'm using Joplin 2.6.10 on Windows 10 with Joplin Web Clipper 2.1.3 on Google Chrome 98.0 and I'm having issues saving web articles from my Company's internal Wiki (so not an Internet public page) to Joplin.

Rarely Joplin is able to save a few images of an article, even more rarely all images, while most of the times it is completely unable to download any image.

Firefox has the same issue.

In the markdown of the note, the images are remaining like this (URLs and folders modified for privacy reasons):



While in Joplin's log I can see this SSL certificate's signature error (URLs and folders modified for privacy reasons):

2022-01-25 15:33:34: "Cannot download image at https://site_url/sub/folder/1623206506958-670.png", "Error: unable to verify the first certificate
Error: unable to verify Wthe first certificate
    at TLSSocket.onConnectSecure (_tls_wrap.js:1507:34)
    at TLSSocket.emit (events.js:376:20)
    at TLSSocket._finishInit (_tls_wrap.js:932:8)
    at TLSWrap.ssl.onhandshakedone (_tls_wrap.js:706:12)"
2022-01-25 15:42:51: "Cannot download image at https://site_url/sub/folder/tip_icon.png", "Error: self signed certificate in certificate chain
Error: self signed certificate in certificate chain
    at TLSSocket.onConnectSecure (_tls_wrap.js:1507:34)
    at TLSSocket.emit (events.js:376:20)
    at TLSSocket._finishInit (_tls_wrap.js:932:8)
    at TLSWrap.ssl.onhandshakedone (_tls_wrap.js:706:12)"

Any idea on how to overcome this?

I've just moved from Evernote to Joplin and I'm really loving Joplin for its speed and its simplicity but this issue is really messing my notes.

Thank you in advance.

@mauriziotroilo welcome to the forum.

I am not saying this is definitely the reason but a similar error message has been reported before on this forum by people on company networks. In those cases it appeared the company was placing its own certificates in the Windows certificate store of their users' machines so it could read / monitor all its users HTTPS traffic. Both Joplin and Firefox use their own certificate store rather than the Windows certificate store. So if your company is using its own self-signed certificate to validate internal intranet sites, Joplin and Firefox do not have that certificate and there are TLS errors.

1 Like

Thank you dpoulton for the welcome!

I'm afraid you're completely right: I'm on my Company laptop, connected to the Company VPN and trying to save articles from the Company's internal wiki, so the scenario is very similar.

Do you remember, by any chance, if someone of the other users that reported this same issue managed to find a way to resolve it?
Have you got a link to one of the old threads, maybe? Or a keyword to find it?

I've already done many searches (mainly on Reddit, honestly) before posting but I didn't find much :frowning:

As a workaround you could try saving the complete page to your laptop, then open the saved version, and clip it.


Thank you roman_r_m, I've just tried and it works flawlessly!

Damn, it's such and easy and effective workaround that now I feel so ashamed for not having thought about it myself :rofl:

Ok, I recreated all the notes that were missing some images and I can confirm that the workaround proposed by roman_r_m worked perfectly 99% of the times.

Thank you very much again for your help, folks!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.