Joplin-search-integration release 0.2.0

@Eduardo Release 0.5.4, has solved the problem of not working properly in duckduckgo search, but your problem is solved?

ref: Joplin Search Integration – 下载 🦊 Firefox 扩展(zh-CN)

Hi @rxliuli
Right, the problem was Firefox + Duck as search engine. But with the new add-on version all is working well, thanks.

Release 0.6.0, supports brave search engine, request source [Feat]: Add Brave search engine for both Brave and Chrome browsers · Issue #90 · rxliuli/joplin-utils · GitHub

hi @rxliuli
I realized after sometimes that the Joplin search integration does not work on my side
I have checked
a. Using different navigator, as chrome, Firefox
b. Using different search engine as duck, google, etc
c. Create and paste a new token using http://127.0.0.1:41184
d. changing plugin configuration.
e. Disabling uBlock Origin
the add.on appear as not active
Captura desde 2023-12-28 09-08-14

and there is not any right side pannel to show joplin search result
Can you help me how to check and find the problem, why is not working?

Joplin 2.13.11 (prod, linux)
Firefox 121.0.0
Chrome 120.0.6099.129
Joplin Search Integration 0.6.0

Always Allow on www.google.com on firefox

On chrome

1 Like

Hi @rxliuli
For example in Chrome I have this set up in configuration.


Sorry, the config is in Spanish.
But does not work.

Are there any errors in the devtools console?

You have to open this extension-window when you were at google.com (or the supported searchengine). The you could allow the site for the extension.

Although I have previously utilized the add-on without the need to enter to google.com or other any extra configurations, I have now followed your new activation process.

Unfortunately, it still isn't functioning. It appears that the add-on remains inactive even after implementing a different setup.

but please check this screenshot

Screenshot from 2023-12-29 07-33-45

you can see add-on is not highlighted like the preceding one, or that it appears more faded compared to the previous line.

Later I have deactivate the others add.on that I have installed to avoid some incompatibility if there was any and still not working.

Later when attempting to access the debug add-on, I encountered an error. I'm unsure if this information will assist in identifying and resolving my issue.

In the example above I have used Firefox with search engine google
Thanks in advance

1 Like

Finally, I found the error. As usual, it was very simple, but I have not seen it.
As I use Joplin in a new laptop with a new Joplin installation even Joplin have a token available, it does not have enable the clipper service for port 41184. After enabling it, the add.on works as was working in other devices. Thanks for assistant and sorry I cannot see this simple issue before.

2 Likes

Sorry, I never really thought about this, I almost always have this option enabled, maybe I should add some more clear error messages or something.


If the joplin webclipper service is not enabled, will such an error message pop up help? @Eduardo


Release 0.6.1, ref: Release joplin-search-integration@0.6.1 · rxliuli/joplin-utils · GitHub

2 Likes

Sure, I believe in the future if I make the same mistake this will be useful to remember us this issue.
The problem was that in general in previous new Joplin installation in new devices, first I updated the web clipper and later the Joplin search integration add-on. In this process you always enable first the port, but In this case, I altered the steps, I wanted to use first this add.on before the web clipper. Thanks a lot for your support.

1 Like

First of all, thank you very much for such a great idea and its realisation.

Unfortunately, I am facing a deal-breaking issue. While my Joplin is running, everything is OK and running perfectly. As soon as I close Joplin, or do not start it at all, every single search engine attempt pops up the error message posted by rxliuli about two posts back.

The plugin thinks that the webclipper service is not enabled, but the real reason it could not connect is that Joplin is (intentionally) not running at all.

I do not know if I am doing something wrong. There are times when I do not want to run Joplin but I still want to use Firefox to "google" things. Is there a way to fix this behaviour? I have not tested with the Chrome browser and plugin combination.

I didn't realize this, maybe this error should be shown in the search results for joplin notes on the right, rather than a blocking prompt popping up?

Oh, I have never seen such a quick response to my report, thank you very much!

The solution you proposed would be definitely way better. If I can also bring two more ideas to your consideration, these would be:

  1. Add a checkbox to voluntarily disable the error message completely. If the browser is not running and the warning was disabled in the configuration, the search page should stay completely untouched by the plugin. No "Joplin search notes" block at all.

  2. Let us modify or even style the "Joplin search notes" title and the whole block.

I see a big potential in this plugin. Bringing the search into one place is a really great idea. Browsers are our modern information hubs so it perfectly makes sense. And we have got much more here. The possibility to immediately start browsing the notes right from from the browser, oh my... I haven't even dreamed of such a functionality.

Add a checkbox to voluntarily disable the error message completely. If the browser is not running and the warning was disabled in the configuration, the search page should stay completely untouched by the plugin. No "Joplin search notes" block at all.

It sounds like just adding an option should be simple, but maybe later, showing a non-blocking error doesn't feel like it will have much impact.

Let us modify or even style the "Joplin search notes" title and the whole block.

I'm not sure about that, maybe some kind of custom css style is supported.

My reasoning for the ability to disable the error message completely is that in the case of proper setup, it is not an error situation in the first place. In fact, there are probably users, like me, that run a browser almost all the time, but Joplin only like 20% of the time. Looking at an error message whenever I use google is not optimal. On the other hand, it is "non-blocking", just a cosmetic thing.

It can be probably styled by modifying the browser's default stylesheet, etc. I will look into it.

These were just my little ideas. I will welcome whatever you do to stop the popup, of course. Thank you once more.

Release 0.6.2, refactored using preact, added better error handling, ref: Joplin-search-integration release 0.2.0 - #66 by CyberDave

2 Likes

When I was writing the initial post, I thought that it could be improved ... maybe this year? I wasn't really expecting a light-fast solution. :slight_smile: Thank you very much.

1 Like

Release 0.6.3, fixed the issue where Brave search no longer works. Reference: [Bug]: Search integration with Brave using search.brave.com no longer working · Issue #92 · rxliuli/joplin-utils · GitHub

1 Like