Joplin on Debian10 Xfce error

Heya! I installed Joplin on my Pop Os without any problem. Also installed it on my android without any problem. And I love the notepad and love your work!

I installed Joplin on Debian10 Buster with Xfce with the command:

wget -O - https://raw.githubusercontent.com/laurent22/joplin/master/Joplin_install_and_update.sh | bash

I got the message on terminal:

You already have the latest version 1.0.201 installed.

And once i tried to launch the app I got this error:

adamfido@debian:~/.joplin$ ./Joplin.AppImage
[5474:0428/122239.144937:FATAL:setuid_sandbox_host.cc(157)] The SUID sandbox helper binary was found, but is not configured correctly. Rather than run without sandboxing I’m aborting now. You need to make sure that /tmp/.mount_JoplinN0RWWp/chrome-sandbox is owned by root and has mode 4755.
Trace/breakpoint trap
(base)

I know you didn’t test it on Debian, but maybe you know is there anything I could try to do?

All the best.
I am fan of what you are doing!

i use debian but not the update script and I’m able to run joplin with XFCE4

I do not use Debian and so have not encountered this problem. However if you search this forum you will see that others have.

https://discourse.joplinapp.org/search?q=The%20SUID%20sandbox%20helper%20binary%20was%20found

Hopefully there is something amongst the results that will assist you.

When encountering an error it is often best to first search for that error on the forum. Unless it is something that occurs just after a new release it is likely that someone has already suffered it and posted about it!!

Thank you for your answer.
What do you mean but not the update script?
How can I have not updated script?

All the best
Adam

Very much thank you
for your answer.
I should dig deeper before posting.
I am on my way to check everything.

Thank you for your patience
and once again forgive my “quickness”

Adam

i just download the appimage by hand

@adamfido

There's nothing to forgive! I was just pointing out that you can often get the answer you need quicker just by searching the forum to see if anyone else has had, and solved, the problem you have encountered :slightly_smiling_face:

:slight_smile: i love hands :-))))

Hey! There is a solution for my Debian 10 XFCE, and Debian 10 Gnome.

All I had to do is add “–no-sandbox” (first double “-”) argument at the end of a executive command.

  1. in XFCE when setting the launcher I wrote:

/home/adamfido/.joplin/Joplin.AppImage --no-sandbox

and now it works fine

  1. in GNOME I edit file:

~/.local/share/applications/appimagekit-joplin.desktop

and add “–no-sandbox” (first double “-”) parameter at the end.

so i have:

Exec=/home/adamfido/.joplin/Joplin.AppImage --no-sandbox

saved a file.
And now it works fine!

Thank you for help.

1 Like