Joplin loads as blank white window - again

Joplin 2.12.18 & Windows 10, syncing with Joplin Cloud.
This is a continuation of problem first reported on Sep 27. I thought that tomasz86 had solved it when he recommended updating my Graphic Card driver. I did this and got Joplin back.

However, on closer examination it was looking different to the previous appearance which reminded me that immediately prior to it going blank, I had installed the macOS plugin which called for restarting it. So I then put it down to the new plugin (probably).

It worked fine but the more I used it, the more I realised that I preferred the previous style. First, I went to the plugin and just turned it off - this had no effect. So then I deleted it (using the option in the Plugins page). Mistake - I was back to the blank screen.

So it does seem to be something to do with the macOS plugin but it's very hard to say exactly what. Installing it caused the blank screen, updating my driver appeared to solve it, but I'm no longer sure that was the case. Deleting the plugin seems to have the same effect as installing it.

I notice that other people report similar problems with macOS but some years ago. Can anyone suggest what I can try next?

The struggle continues...
I had convinced myself that the problem was linked to the macOS Plugin - which I first turned off and then deleted - with no success.
Since I have no way of accessing the desktop application to explore further options, I decided to completely uninstall the software (...Program Files/Joplin/Uninstall Joplin.exe) and start again.
Successfully removed it and then ran Joplin-Setup-2.12.188.exe. All seemed to go smoothly but the result was the same - blank white screen.
So maybe it isn't to do with macOS plugin at all?
I should add that both my Android applications are working (and syncing) fine.
It's very hard trying to do all this on my own. I'm out of my depth - could someone please advise me?

Uninstalling the Joplin program does not uninstall any data / config / plugin files you have, so if there are any errors in that data they will persist between installs.

You could try resetting Joplin to see if it opens and displays again.

Make sure Joplin is fully shut down and rename C:\users\username\.config\joplin-desktop to something like C:\users\username\.config\joplin-desktop-broken. It's probably best not to delete this folder at this stage. Then see if you can start Joplin. If Joplin starts up and displays you will just have the default notes and settings and a brand new joplin-desktop folder. Joplin will be as if it had just been installed for the first time.

If all is OK, connect the client to Joplin Cloud and, as it is effectively a brand new install, it will then download your notes.

Note: Do NOT try to speed things up by copying anything from C:\users\username\.config\joplin-desktop-broken into your new C:\users\username\.config\joplin-desktop folder.

Thanks very much for responding – I have had to make a couple of changes to your suggestion as I will explain below, but I’m afraid the outcome is no different. Maybe you could advise whether my different route is not what you had in mind.

I suspect that you are talking macOS or Linux paths while I’m currently stuck with Windows (my Linux laptop is currently out on loan).

Firstly, you refer to C:\users\username.config\joplin-desktop. The closest folders I have are C:\Program Files\Joplin and also C:\Users\Username\AppData\Roaming\Joplin.

Having tried to rename both, Windows refuses on the grounds that “a file or folder is open elsewhere”. I know you said to make sure Joplin is fully shut down but I’m not quite sure how to achieve that when I can’t properly open it in the first place – the best I can do is click on Close (Ctrl-W doesn’t work). Even when closed, there is still a “lockfile” appearing in the Roaming\Joplin folder – maybe this why I can’t rename it.

So I couldn’t see any alternative to using the Uninstall Joplin.exe option (in the Program Files\Joplin folder) which wipes out the contents of Program Files\Joplin but doesn’t seem to touch the content of AppData\Roaming\Joplin. However, it will now allow me to rename it to Roaming/Joplin – Old.

Then I reinstalled the program using Joplin 2.12.18.exe – but it is still giving me the blank screen treatment.

What is going on?

Regards, Bob


To be honest it couldn't be much further from what I had in mind...

The path to the Joplin data

C:\Users\<username>\.config\joplin-desktop (where "<username>" is your account username) IS a Windows path. It looks like this in Win 10. In the image below the user account used as an example is "vbox".

Making sure Joplin is shut down

Unless you have Joplin automatically starting when you log in, logging out and back in (or rebooting) should stop Joplin.

If you do have Joplin starting when you log in then logging out / rebooting will not work. If this is the case press "CTRL+ALT+DEL" and you will get a blue screen with several options.

One option is Task Manager, select it and the task manager will appear.

Click any displayed task that says Joplin / shows the Joplin icon and press the "End Task" button. Do not stop any other tasks, only the Joplin ones.


Then do the "folder rename and restart Joplin" thing as I described above.

Many thanks – it’s working again.

I think my problem was mis-reading *<Username>.config* as *<Username>.config* which then lead me off on a wild goose chase.

And even then I didn't get it right!
I meant:
"...mis-reading *<Username>.config* as *<Username>.config* ..."

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.