Joplin is Stripping the Dollar symbol

Operating system


Joplin version


Desktop version info

Joplin 2.12.19 (prod, linux)

Client ID: fd053f8b545e44c7aad12a5cb7f15c22
Sync Version: 3
Profile Version: 43
Keychain Supported: No

Revision: 7081046


Rich Text Editor

What issue do you have?

I try to record Passwords for every website account that I have in Joplin

however, it refuses to Record the $$ symbol in the right pane, it shows in the Left pane, but not the right pane.

this needs to be fixed.


$ brings up the katex math formatting. If you want the actual $ symbol, put a \ in front of it.

I don't think it would have been a problem but that your password has two $s. Try
it with slashes in front of each $.

@JohnC welcome to the forum.

As @karl1 has pointed out the dollar signs are a "trigger" symbol for Katex mathematical and chemical expression notations. You can see that the font colour has changed for the numbers "1020" in the markdown pane and the font type has changed for them in the render pane on the right. What was said about "escaping" the dollar signs by putting a backslash before them will work.

However, Katex is switched on by default so if you do not actually use Katex / mhchem notation another option for you is to turn it off by unchecking,

Tools > Options > Markdown > Enable math expressions (wysiwyg: yes).

Your "password" or any text like it will then render correctly as it is.


1 Like

If you want to keep Katex switched on another option is to mark the password string as code. When classed as code any text between the two backticks is treated "literally" and so does not trigger any rendering of Katex, Markdown or HTML tags.

In the image below it is not just Katex causing the problem, it is also text that Joplin sees as Markdown and HTML tags in the text.


1 Like

Thanks all,
I will just change my habits on using the $ symbol in passwords, not use it at all.

I experimented with using BACKSLASH in front, then a Space, and then using the $ symbol, but once it is entered once, the 2nd and 3rd times it omits it in the right panel anyway.

Can't have that, so will just never use $ in passwords.

When I started using Joplin, I also thought about storing data with keywords in Joplin. I dropped that thought for security reasons and started with KeePass instead. May I ask why you’ve choosen Joplin?

Because KeepassXC is not working for me, it refuses to work period in Linux Mint LM21.2 Cinnamon, so I unlinked it from the browsers, and now letting Firefox control all passwords.
I then record that and put it in Joplin for quick access when I need it.
I used to use LastPass, but they got hacked, and I changed all of my passwords, and unlinked from LastPass

Thank you for your insights! KeePassXC I have never looked at it closely.

Have you ever looked at vaultwarden? Easy to install and you can use the official Bitwarden clients.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.