Joplin in AUR - doesn't build

I’ve been trying to update Joplin since weeks, but, all the time it returns failure.

The bugs are reported in AUR ->

Will it be solved in the near future? I know that I can download using Bash or the Appimage version. But, AUR packages can easily be updated along with other updates regularly as you might be aware of.

If you check the Joplin GitHub issue tracker, there have been a small number of issues with the AUR version. The problem is, we have no control over it. It’s not maintained by the dev team here; its maintainer also seems to not be too active, especially here. Because of how Arch and its derivatives handle access and whatnot to that repository, none of us even qualify to be able to take over its maintenance.

It’s as frustrating for us as it is to you. I’m sorry if that’s not what you wanted to hear or was of any direct help to you. :crying_cat_face:

There is no way to create another package or take over the paackage if the original packager stops maintaining it?

Not in any official capacity. Many of us do this in our spare time and i already have several projects outside of Joplin I’m involved in. I’m almost certain I’m the main Arch user on the team so I’d be the most qualified but just don’t have the time or energy to be able to keep it maintained.

Of course, if you’re willing to go through the process required by AUR to be a maintainer on it, feel free to get on it. We definitely could use the help.

1 Like

I use Manjaro and compiling from AUR works for me. I run the latest version.

Do you have tips or further information @okoetter to help out @avndp and possibly anyone else that are running into this issue? Saying it works fine for you without giving full context on why it works or even the fact that you are on Manjaro, a derivative of Arch, that doesn’t directly help anyone.

Also, what AUR repos are you both using?

EDIT: to build Joplin from source, you will need to run sudo pacman -S rsync if it’s not already being installed by the AUR. I did a test build earlier and discovered that was missing, causing a build failure.

I don’t know Arch Linux and I don’t really know why it compiles fine on Manjaro, I enabled AUR in Pamac, simply clicked on install, waited some minutes and bingo. Sorry for not being more helpful, just wanted to point out that the AUR package is not completely broken.

1 Like