Joplin doesn't work after manual transfer from one system to another

I had Joplin installed on my laptop with Ubuntu 16.04 and tried to transfer my Joplin notes to the fresh system with Ubuntu 18.04.

Synchronization didn’t work on my old system for unknown reasons but I postponed the solving of this problem to better times. I used Joplin on this laptop only. The notes itself I hold in the JOPLIN folder in pcloud.com paid account (2TB lifetime).

So, my actions to transfer

  1. I created the same user on the new system. Hence, home folders (~) have the same path on the old and new systems
  2. I backed up three folders: ~/.joplin, ~/.config/Joplin, ~/.config/joplin-desktop
  3. I copued these three folders to the new system exactly to the same location they originally go from.
  4. JOPLIN folder with notes is in the same location on the new system as on the old system

Then I tried running Joplin as: $HOME/.joplin/Joplin.AppImage and received a Joplin application with error message:

Completed: 09/05/2020 21:49
Last error: Error: Fail-safe: Sync was interrupted because 100% of the data (315 items) is about to be deleted. To override this behaviour…

Besides, there is red Conflicts tab under the Notebooks menu containing some of my notes (not all) and two other tabs with some of my notes. Is it possible to recover my notes? What did I miss in Joplin transfer?

Thank you