I've installed Freehand Drawing but the icon doesn't appear

os: Ubuntu 22.04 Joplin version: 2.9.17

I'm new to Joplin. I've just installed an addon called Freehand Drawing. According to the documentation an icon should appear in the editor's ribbon showing a fat looking pen, but it doesn't appear.
I've tried re-installing, but that made no difference. I'm pretty sure I'm doing something wrong as I really don't know the software at all.
If anyone can help, it would be much appreciated. It's a key feature for me.
Thanks in advance.

1 Like

Is there any error in the console? How to enable debugging | Joplin

Also are you using the Markdown Editor or the Rich-Text Editor?

I have just loaded the plugin to test this and it seems that the "fat pen" icon is only visible when using the Markdown Editor.


Markdown Editor ^

The Rich-Text editor just displays a cog. It seems that the Freehand Drawing plugin is not compatible with the Rich-Text Editor.


Rich-Text Editor ^

1 Like

Related issues:

Switching to the markdown editor to insert/edit drawings is very inconvenient. One solution would be to temporarily switch between the CodeMirror and Rich Text editors.

Unfortunately, while I should be able to use the :toggleEditors command to switch editors, I don't see a way to detect whether the CodeMirror or rich text editor is open with the plugin API.

Thanks for taking the time to respond (and so quickly!). It's very useful to know that there is a debugging mode, so thanks for that. The problem has been solved by the second respondent (dpoulton)

Thanks for the very timely response. You're right, the pen only appears in the editor that shows the layout instructions that I've learned to call the markdown editor.
Sorry about troubling you for something so obvious, but I think that's what happens when starting new software. :slight_smile:

1 Like

It's not that obvious, especially if it is all new to you, so apologies are certainly not required :slight_smile: .

Also... welcome to the forum!

2 Likes