Home / GitHub Page

Issues with onedrive

hey! since the latest version of joplin i got on 2 different machines (windows 7 and 10) error during sync, the error is not more specified. iOS versions are syncing fine with onedrive.

I now changed to dropbox (with the same notebooks etc.) and sync with dropbox works without any error, so it looks like a particular OneDirve issue.

in total there are about 1200 notes, but no attachements) in total all files are about 3 MB

best
dirk

Joplin 1.0.195 (prod, win32)

Client-ID: e38c2eca06a8417794a1af1bc6e54229
Sync-Version: 1
Profil-Version: 28

Revision: f4a562bc (master)

Hi, I have the same problem. Unspecified Error when syncing from desktop client (Linux), android works/worked fine. I tried to delete everything (apps, configs, onedrive folders), but the problem still persists after starting from scratch on latest versions.

Some info for developers:

It started after updating on desktop linux from 1.0.168 to 1.0.195. It asked for new encryption method and then i clicked to re encrypt everything. Then it probably wanted to resync the files when I started to get errors. It will run sync, print “created remote items X/Y”, x,y are numbers, but it will stop on random x and show “last error: Error”. Even when it looked like it finnished (so x=y), next time it will start “created remote items” again and stop on Error.

I also had around 1000 notes. But this problem persists even after clean start with few notes. Sometimes it runs ok, sometimes not.

hope we will find what’s wrong
marek

Joplin 1.0.195 (prod, linux)

Client ID: a5b3cc21a70b4c8b883eb1e13e9ea1d5
Sync Version: 1
Profile Version: 28

Revision: f4a562b (master)