Issue markdown

Hello everybody!

When I'm in edit mode, I think I'm in markdown mode so for example when I write:

# This is an H1

If I exit edit mode it shows me the same
# This is an H1.

Shouldn't it show the text without the # and converted to H1 when I press display mode? I mean:

This is an H1


When you say 'edit mode' and 'display mode', could you explain what you are actually using? I noticed your other posts are often using the rich text editor which will escape any directly entered markdown tags so that they aren't rendered. On the other hand if you are in the markdown editor then you should be seeing them taking effect in both the editor and the viewer.

1 Like

if you choose the split screen mode with the md editor in one half and the display showing immediately, then it will show as you wish and you avoid the inconvenience of not knowing whether you are in wysiwyg or not.

1 Like

What do you mean exactly with exit edit mode?

Joplin offers two modes, shown in the upper right of the program window:
I prefer the "markdown mode". There you can type a # heading to achieve a heading, level 1.
This is shown in preview as


which can be shown in a second panel or toggled, depending on the settings ViewLayout Button Sequence → …

If you toggle RTF editor and markdown editor with the shown buttons, this switches interpretation of the text currently hold in the editor.

# heading typed in RTF editor will become \# heading in markdown editor.
This leads to a render difference: Markdown is rendered to


RTF is rendered to text

# heading


I am very grateful for your help to all :slight_smile:

I've been looking at the option to see. The problem is that to me the split screen is never shown and it is strange.
I have the View mode (see note) or graphical edit mode but it never shows in markdown.
For example this is my setup and split screen or markdown mode is never visible:

However, in a youtuber I have seen that the markdown and split screen mode is shown:

Is it an option that I have to activate somewhere?

Thank you all!

In the top right of the screen is a little button between i and the bell (sorry im on mobile so can't annotate a nice pic for you). It will be active when you are on the viewer and will cycle between editor, viewer and split.
It should also be in the view menu on the top menu bar.

1 Like

Click on the Markdown Editor Button, to move from the Rich Text Editor to the Markdown Editor.

Click on the Toggle Button.

To cycle between the Markdown Editor, the Markdown Viewer and the Split View


Hi everyone,

I am very grateful, as a simple button I have not been able to see it!
Now I do like how it works, thank you very much friends, you are all very kind !! :hugs:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.