Ignore TLS validation errors when installing plugins? (company MITM TLS firewall)

Hi all,

I'm using Joplin 2.9.17 on Windows 10.

I can't install plugins because I have a corporate MITM firewall intercepting TLS traffic, reading my emails, hacking my code, etc.

The plugins tab shows this error, which makes sense (electron app -> openssl -> MITM ssl cert -> validation error, I assume):

Could not connect to plugin repository.

Is there a way to add my corporate CA cert specifically for plugins? Or even better, to simply ignore TLS cert errors for plugins?

I see in Synchronization, we have both... "Custom TLS Certificates", and also "Ignore TLS Certificate errors". I'd love to have similar settings for plugins.

I don't care at all about the integrity/security/privacy of joplin plugins specifically related to my corporate firewall. And I would love to be able to install plugins using this tab. I can install some plugins by downloading the JPL files, but it looks like not all plugins provide ready-made JPL files (e.g. I wanted to install joplin-template plugin, and hit this roadblock yet again).

If there's no current way to do this, I'll open a github issue for it.


1 Like

If you go to Joplin's plug-in site you can search for the template plugin and get a download link for the jpl file.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.