How to use external editor?

  • The version you are using. Joplin 2.0.11 (prod, linux)
  • Sync with Nextcloud
  • The operating system you are using: Linux Mint 20.1 Cinnamon 4.8.6

Hello! I would like to use the external text editor. But when I click the button, "Stop" appears, but no editor opens. Somehow I expect this to happen.

Now I've read a lot about it here in the forum and tried to somehow save my desired editor in the settings. But no matter what I write in the two lines (path, arguments), it doesn't work. If I click on the button, nothing happens, not even "Stop" appears.

Maybe someone has an idea what I can do there, or what I should write in the two lines or how I can get Joplin to at least open the standard editor.

That would be really great. Thanks in advance.

@Steffimania, you need to point Joplin at the editor you wish to use.

From the menus pick Tools > Options, then in the Settings that come up, pick: General > Text editor command

There you can browse and set the editor you want to use.

Many thanks for your response.
I've already tried that.
According to the terminal query , the program is in / usr / bin / Zettlr
But if I browse there via Tools / General, Zettlr is not displayed and no other program (xep or Typora) that is stored there. When I browse there with Nemo, the programs are displayed.
And when I put the path in the command line, it doesn't work either.


That is strange. Here I'm using typora, and have entered the path where I've installed it, in my case /home/john/bin/Typora/Typora and it works as expected. So don't know what's going on, hope you get it sorted.

1 Like

Did you use a flatpack or snap packages? Because they use sandboxing to isolate Joplin from the OS/Other Apps.


Many thanks for your response. Yes, I have installed a flatpack. There is only this in the application management of Linux Mint.

So I would have to uninstall it (export all notes beforehand) and then download and install the official package from GutHub? Then import everything again and see if it works?


I found the solution :slight_smile: In the post linked from Profile - JackGruber - Joplin Forum Problem using external editor - #11 by james-carroll there is a link to another post: Launch external editor (Linux, Ubuntu/PopOS, flatpak) - #3 by fnl

One amendment for completeness, if others have a similar issue and if you want to spawn non-flatpak apps from a flatpak-installed Joplin, such as Typora (which in turn isn't using flatpak), you can use this configuration instead:

/ bin / flatpak-spawn
--host / usr / bin / typora

I did that and it works!


Many thanks for the help :slight_smile:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.