How can I install Typora as external editor?


I have installed Typora from Flatpack and it runs as it should. I am, however, unable to configure Typora as the external editor for Joplin to use, because I am unable to locate an executable.

All paths tried so far have not worked. Has anyone successfully configured Typora as the extefnal editor and can supply some hints?


Joplin 2.6.10 (prod, linux)

Client-ID: 3708fbfebb3646c787c57619e7200257
Sync-Version: 3
Profil-Version: 41
Unterstützter Schlüsselbund: Nein

Revision: 98fba37

This may help

Unfortunately your tip does not help as I am not running Windows, but thanks for the quick response. If you come up with a solution suitable for Linux, please let me know.


I'm sure a flatpak wizard will turn up at some point but because it is sandboxed I think you need to launch it with magic.

For example to launch it from the terminal you would need to run flatpak run io.typora.Typora.

If you are also using the Flatpak Joplin then the maintainer has included a useful guide to getting external editors working, I don't know if this will be of any use if you don't have the flatpak version though.

1 Like

I install Joplin directly from githubusercontent, but your suggestion works nicely if I separate the command line parameters from the actual command, so thanks for that.

If some flatpak wizard comes up with a more elegant solution I'd like to hear it but for now, it works fine.

Thank you very much,

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.