How to disable WYSIWG

How do I disable the WYSIWG editor? The menu options under View don’t match the instructions linked from the “introduction post” link at the bottom of the screen.

I don’t dislike the WYSIWG editor, but the issue I have is that it keeps deleting the [TOC] entry, which in turn means that the TOC sidebar (Toc as the sidebar) disappears. If I click on Code View it jumps to the WYSIWG editor, so I want to disable it from appearing permanently (well at least until I revert whatever setting, but at least not to make the program not switch to WYSIWG as easily as clicking on the Code View button).

Joplin 1.0.224 / Windows 7

If you want to hide the Code View button, you can add…

    display: none !important;

… to Settings > Appearance > Advanced > Custom stylesheet for Joplin-wide styles.

Just a heads up, this might need to be updated if the navigation bar changes.

Edited: whoops, i forgot the brackets in the original comment!

So that solution didn’t work for me, but armed with the knowledge that I could fiddle with the UI in this way, a quick search revealed how to hide the button here Code view button, which did work.

1 Like