Help required for testting the video embedding plugin

It would be great if anyone can help in testing this pull request

Open Joplin development folder on your VSCODE

open the terminal (Basically, we are adding a branch from someone else’s fork locally Here’s the StackOverflow answer)

do git stash so all your uncommitted changes are saved

Here we are adding the remote which contains the required branch branch (my fork of Joplin)
git remote add rishabh

(fetching all the branches from the remote(my fork of Joplin))
git fetch rishabh

(checking out to the desired branch)
git checkout -b <add a branchname> rishabh/embedVideoII
eg: git checkout -b temp rishabh/embedVideoII

cd ElectronClient/

npm start

go to settings and plugins and enable the plugin, embed video

on pasting a youtube link a youtube video player should be automatically generated.

1 Like

Hey @rishabh.malhotra,

There is a better way to do this actually.

git remote add upstream
git fetch upstream pull/2747/head:embedVideoII
git checkout embedVideoII

This will get you your branch locally.

I’ll test out your PR and get back to you.

1 Like

yepp your commands looks cleans…I’ll try now.

Hey @rishabh.malhotra
I tried testing your feature in my system. It absolutely working fine…Great work!

1 Like

I've tested the current feature on my system. Everything works fine and as per the spec.
I would like to suggest something. I don't know if this is in the scope of your PR or not but if the user doesn't have an internet connection, it just shows a blank screen. Maybe you can add a placeholder image there or something. Just a suggestion. It might be hard to implement so totally upto you. Good Job though! :relaxed:

@laurent thoughts?

I was working on the issue: and I figured out that while exporting into HTML file or PDF File, RAW HTML get exported instead of rendered HTML so I thought of your plugin I was curious how youtube video thumbnail looks like in PDF so I exported a note with youtube link and result was nothing! Note didn’t get exported in PDF I tried again then log shows this:
Printing C:\Users\Zaid Kesarani\Desktop\heello - Test.pdf to pdf disallowed, already printing.

So I think we need to export the rendered HTML instead of exporting RAW HTML.