[Help pls] Fail to get authorization from Dropbox

Hi there,
Thanks for making such a wonderful app. But I’m experiencing a problem while set it up on my MAC. Described as below:

  • Joplin for Desktop 1.0.216
  • macOS Catalina 10.15.5

When I was trying to get authorization from Dropbox, the app always show me a fail message after long time waiting. I’m using V2RayN, and it works fine with all other apps. However, Joplin worked perfectly on my iPad with the same process under the same settings.

The warning message:

I’m not a coder, but still, tried to provide some log records for your convenient:

  1. Console message:
  2. log.txt

Hope you can help me with it. Highly appreciated!

Whats V2RayN?

A proxy client which support shadowsocks, v2ray etc.
I’m in China and Dropbox is sadly blocked by the G(reat)F(ire)wall… :sad:

It could be that the GFW detects the connection attempt in this context and block it.

Hmm, or it could also be related to

But the VPN should pass the certificate untouched to the app, shouldn’t it? And in that case all fetch-blob would see is a valid certificate.

Yes, I agree. But if it works with Joplin on iPad, it must be something that has to do with Android - or with something that was added to the code in the meantime. Usually Android and iOS releases are mostly far apart. So the next iOS release might break as well.

@laurent @tessus Thank you for your concern.
It seems I should try to modify the config file, right? I'm sorry for knowing almost nothing about coding. But I'd love to give it a try. But first, where can I find the config file? :thinking:

Unfortunately there’s not much you can do. Unless you compile a new .apk for Android and install it on your phone. Also, we don’t know, if the issue I referenced really is the culprit.

Oh, OK. That's too bad.
Perhaps I could install the terminal version to see if it has the same problem.
Thanks anyway! :beers:

Oh, I’m very sorry. I mixed a few things up. Your issue is on macOS, not on Android. So please ignore my previous posts.

Edit: I’m very sorry for the noise. Apologies to both of you: marsroy and laurent

That's OK. :smile:
So, anyone else has any ideas about the solution?
Really really want to use Joplin on my MAC...

This is from a post in Stackoverflow on the very error message you are using: https://stackoverflow.com/questions/53593182/client-network-socket-disconnected-before-secure-tls-connection-was-established

As it seems, the GFW is blocking out your requests to dropbox.com.
I assume V2RayN is a VPN that works laptop wide.
Could you please do one thing: Open a Terminal from finder and run traceroute url
In place of url first put in the URL of a site you know is not blocked by GFW (like www.alibaba.com or something like that) and run the command.
Run the command a second time by replacing url with www.dropbox.com.
Then please post the output of both commands.

Thank you in advance!
V2RayN works perfectly on my iMAC, including browsing, in terminal, or with other installed Apps, such as Dropbox App. So that's why I don't understand why it doesn't work with Joplin desktop version.

Here's the test result:

Thanks again~ :clap:t3:

Looking into it.
Whenever you post output from a terminal/console/log, it is better to paste in the text rather than give a screenshot because it is then possible to copy text from it. :smile:

Ah, sorry. How stupid I am! :sweat_smile:

Here's the text:

roy@RoydeiMac:~|⇒  traceroute -m 10 www.alibaba.com
traceroute to cloud-secgw-hz-scproxy.alibaba.com.gds.alibabadns.com (, 10 hops max, 52 byte packets
 1 (  178.989 ms  2.363 ms  2.407 ms
 2 (  2.534 ms  2.542 ms  2.534 ms
 3 (  4.087 ms  181.608 ms  4.419 ms
 4 (  6.725 ms  141.145 ms  6.734 ms
 5 (  4.895 ms  14.605 ms  5.242 ms
 6 (  4.387 ms (  5.679 ms (  183.766 ms
 7 (  188.285 ms * *
 8 (  212.166 ms (  219.046 ms (  223.051 ms
 9 (  213.362 ms (  213.501 ms (  217.073 ms
10  * * *
roy@RoydeiMac:~|⇒  traceroute -m 10 www.dropbox.com
traceroute to www.dropbox.com (, 10 hops max, 52 byte packets
 1 (  179.159 ms  2.905 ms  2.565 ms
 2 (  2.682 ms  2.588 ms  2.748 ms
 3 (  7.886 ms  4.464 ms  12.926 ms
 4 (  4.387 ms  7.840 ms  7.361 ms
 5 (  6.550 ms  6.206 ms  7.499 ms
 6 (  12.372 ms  12.281 ms  15.852 ms
 7  * * *
 8  * * *
 9  * * *
10  * * *

BTW, I also did some simple test, and found that the problem perhaps is caused by the V2RayN client and VMESS protocol (as @laurent and @tessus mentioned before). Just now I changed the VPN client on my phone (Google Pixel 3) to Shadowrocket, which is the same as the one on my iPad, and it worked! :tada:

So it seems what I need to do is to switch the VPN client on my MAC to Shadowrocket. However, V2Ray is far more better than Shadowrocket, and it's very important for a person like me who live within a Wall... As a rough solution, I will switch between two VPN clients while sync Joplin. :stuck_out_tongue_closed_eyes:

Still looking forward to an official fix for it ~ :smile:

hello, I have the same question in windows,
OS: Windows 10 professional
Joplin: Joplin 2.5.8
synthetic methods: AWS S3(Beta), with Tencent cloud which is a cloud privider in china.
V2RAYN is uesd to break the CHINA GFW in my destop.
then :
"client network socket disconnected before secure tls connection was established"
forgive my poor english :sweat_smile: