Help for writing here?

Operating system

Android

Joplin version

2.14.9

Desktop version info

Joplin 2.14.17 (prod, linux)
ID client : 3351cc8ec0bf45d892c41f9c405f6d46
Version de Synchro : 3
Version du profil : 46
Trousseau supporté : Non
Révision : 094175c

Autolinker: 1.0.4
Combine notes: 1.0.1
Email Note: 1.2.2
Freehand Drawing: 1.10.1
Markdown table calculations: 1.0.5
Paste Special: 1.1.2
Simple Backup: 1.3.6

Sync target

Dropbox

What issue do you have?

I asked a question here more than one month ago and the only reply I got was the robot shutting it down after 30 days...
I presume I wrote something incorrectly, so any advice on how to express myself here would be very welcome!
FWIW, my question is the following (and symptoms are unchanged) :

One difficulty with fixing this is collecting enough information to determine what's happening.

Phantom notes

I've just released a plugin that should provide additional information about notes and resources. It may allow determining the IDs of (and possibly deleting) the unopenable tasks at the top of the note list. So far, I've only tested it on Joplin desktop.

I plan to test on Joplin mobile (the 3.0 pre-release) tomorrow. Edit: v0.0.2 should work with the 3.0 pre-release.

Attachment download issues

To try to debug this, I suggest searching the log for the ID of one of the resources that's failing to download. To do this,

  1. Open one of the problematic notes.
  2. Copy the resource ID.
    • In ![test](:/12345678901234567890123456789012), the resource ID would be 12345678901234567890123456789012.
  3. Go to "configuration" > tools > logs.
  4. Click the search button.
  5. Paste the resource ID into the "filter" input.

Are any log messages/errors visible after doing this? If so, they may help determine what the issue is.

1 Like

Thank you @personalizedrefriger !
I just tried the new plugin on my Linux Joplin instance : the detail it shows is impressive, but indeed the Linux instance runs OK.
I then considered installing it on Joplin Mobile, but on my 'faulty' tablet I am with the ordinary 2.14.9 release, on which I don't see any way of installing the plugin.

What happens if I download the current prerelease 3.0.3 that I see on Github: will this version reuse my current setup and notes, just silently replacing 2.14? Am I right in expecting then a way to install the plugin?

Thank you for taking care!
As I am again leaving for a mission that will prevent me to react seriously until next Wednesday, don't feel constrained by time here.
If you think I can easily upgrade to the Android apk 3.0.3 I'll do this right now and try to just delete the faulty task with the plugin, assuming I can see how to install it on 3.0.

(I am quite confident anyway, as I imagine if nothing works I also could just uninstall Joplin from the tablet and then reinstall it, redoing all the sync settings, keys etc. -indeed what prevented me to do it until now is I fear a super long sync, having lots of notes and pictures...)

Thank you again!
Hervé

Good question — I'm not sure. I can test on an Android emulator and report back.

I remember I did install the first beta version that incorporated creating vectorial drawings because it was extraordinary for me, and when doing this the beta android actually lived separately from the nominal. Maybe 3.0 will do the same?

When I publish a beta/testing version on my fork, I change the application ID to prevent it from conflicting with non-pre-release versions of Joplin (see the __build_instructions.md files attached to most of the releases on that page). I don't think this is done with the official/versioned pre-releases.

1 Like

OK, I just downloaded 3.0.3 and indeed it replaces the previous version. At this moment it is slowly re-deciphering hundreds of files apparently (and I have an orange panel at the top of the notes announcing that 'some objects couldn't be deciphered', but I suppose this will calm down at the end.
I come back in a (possibly long) while when deciphering will be over.

My experience here is the official pre-releases just update the app and otherwise keep everything intact.

Your Joplin Debug Tool plug-in works as expected here on Android Joplin version 3.0.3, although I have not yet had a reason to use it to permanently delete a troublesome note

2 Likes

OK @personalizedrefriger switching to prerelease 3.03 apparently did the trick : my phantom task has disappeared, all doiwnloadable pics seem to download, and I did add the debug plugin on android, which does show what it is expected to show, while I didn't need to use it to delete something.

The semi-scary 'some objects couldn't be deciphered' warning seems to have disappeared too, while I had to insist requesting redeciphering a couple times.

To people downloading 3.xx you may mention there will be a possibly long re-deciphering of almost everything (is this due to another way of handlig the database? After this, the app seems more responsive!)

Thank you for your help!!
Hervé

In a recent version we improved how objects that can't be decrypted are handled, so maybe you had many of these and they got processed in this version

It was unclear, but in v3 after the 100+ decryptions there remained two lines when focussing on this point in the settings : one at top was a generic warning not detailing how many objects were left, and one at the bottom apparently showing a single resource ID.
I then just asked to try deciphering again, which apparently had the warnings disappearing, but they reappeared after a while. Then re-asking to re-decipher solved it, or at least they are scared out for longer :wink:
Thank you again for your time, and all this work on plugins!
Hervé
[edit] In fact I still have the "couldn't be deciphered" alert in the end on Android v. 3. see post below...

1 Like

By comparing the numbers of elements in the 'sync status' panels on the Linux and on the faulty Android, I see there is just ONE element more in Android, which (IMHO) generates the sync status error.
I installed the Note Info plugin, I see I can do a lot with it including deleting a given note, but as I don't know how to select the troublesome unsynced item I just cannot use the Note Info to eliminate it....

Then I tried the approach desrcibed by @personalizedrefriger in post #2 above : I got the log text associated to the error, below, but I don't know how to kill the related item...:

05-08T18:04:26: "DecryptionWorker: error for: 1f7cb89cb721480ebe5040ac8d99a18c (notes)", "TypeError: Cannot read property 'id' of null
TypeError: Cannot read property 'id' of null
    at ?anon_0_ (address at index.android.bundle:1:1699466)
    at next (native)
    at fulfilled (address at index.android.bundle:1:1685034)
    at tryCallOne (/root/react-native/ReactAndroid/hermes-engine/.cxx/MinSizeRel/5p1x2e66/arm64-v8a/lib/InternalBytecode/InternalBytecode.js:53:16)
    at anonymous (/root/react-native/ReactAndroid/hermes-engine/.cxx/MinSizeRel/5p1x2e66/arm64-v8a/lib/InternalBytecode/InternalBytecode.js:139:27)
    at apply (native)
    at anonymous (address at index.android.bundle:1:249413)
    at _callTimer (address at index.android.bundle:1:248362)
    at _callReactNativeMicrotasksPass (address at index.android.bundle:1:248526)
    at callReactNativeMicrotasks (address at index.android.bundle:1:250501)
    at __callReactNativeMicrotasks (address at index.android.bundle:1:152257)
    at anonymous (address at index.android.bundle:1:151350)
    at __guard (address at index.android.bundle:1:152098)
    at flushedQueue (address at index.android.bundle:1:151261)
    at invokeCallbackAndReturnFlushedQueue (address at index.android.bundle:1:151204)", "{"user_data":"","master_key_id":"","conflict_original_id":"","share_id":"","is_shared":0,"encryption_applied":1,"user_updated_time":1689677985325,"application_data":"","source_application":"net.cozic.joplin-mobile","source":"joplin","is_todo":0,"markup_language":0,"order":0,"latitude":"0.00000000","encryption_cipher_text":"JED0100002207beffaaa79985462fab6c20bd2248a5d500080c{\"iv\":\"xcndKt4fi1OwmUqmqzTbCQ==\",\"v\":1,\"iter\":101,\"ks\":256,\"ts\":64,\"mode\":\"ccm\",\"adata\":\"\",\"cipher\":\"aes\",\"salt\":\"ujZYJ8PSu94=\",\"ct\":\"JFYyG4FAS1yRUuRmbMs9r3+Vn2QhpWnBGHpcQV2iFgrRw8Eb1RkLNqFKn/4cF0sSBuXu3BSZGd1SuwpaXfk+rQCpt4mIbrfy+I0/lWoQqls+CUa+/fdld4cd0i/5BYMTyO/465O5QFwjf2LUxiQecYohmw0Fkb85c/ocVXK1rtvqJiDe3Rt+tyMPwa0G0GrC2rlUN4sn7R6Lk9YQvF5UXN70+cyS1v5+R6OVcalZ7Kv4fCQFM6ObuuQDs5NLUwlsPc4DS0bwgSafdinsRcMk1X3mxaS+qJry2HYh/2qOZqoG+XcBkgBxXKtJzgGevnrK7rIbHti0NblwJgItq4iWuM0FwUzaNxlUVeFKMKbIUvWEAIegEjeJFgVtCohekDOKV6tEr2hCU+xJsSedp/wZJsjIER33rxtGKZbsWE3qipBTA76goWbSkDp7t/N+dgyuWUy7YoeDQ0zd7TRxtFd3NkuVCCvNlVzm3MkRsAuIV+Yz8zc21PSJHqciruQwe0Uf7BH+vX4wnwd00CbHK11P+74H+Z416fR+tC1lYQSun+/Y/B+QrtMMCx5ypgve25MCZwkxpnd7BI0nvYwHunTTQoxrli9cSQVUiw0GNP3uHKmE8m0Ev5XiHfRWkup8xwET12keri5n4T834S0Jj++u9/jBlmjcN8eAIHROtWWMLar+wMKeAjANp9gtnMwjU1t+/0im8Pbt4oskc8SCZLlcfIOW98FOAGpqNy6MpaJzrpNwhfvrdS8o1F9EFbrOzHTCoBH0IyYLx4Tp44YvSvuS1RK3WgQRglsrDedu41aB3Ls1gKRly6DHBjun8VneqRsIdidsz4ijoPywqkhmPVOvhId4dH7VCOZtt2FSVm7XPhjTDLQt91K9Lt+Yl8AMLKv1eJWrwSmBfasY+TpMGerVGW9Y0aA5cXmCo8c7Cb2IybuNID6mTOH4ByAmb7W1r7mPPrCUWxkmy+im5xT45Qy+vxgfK6+DMmfwAe5W9ikjSxt+HYfNao7vG3hjfqtGPnS3VniOb3XOGLzfrOR1pfos/aTpuvklVqp2D8XnaYOrPJkx3zRnmkFneG2La1iB9kMBO9xVF5h+5EytrWRYLof1NhBZNJ5iXUZSEH72I9a/u9zreFRCsWc3PBnI33qWB1oOeg1bboSwVk50HTASa9nSal2JiwQf7vNytKEBrgWX9OVSUbj+JTD6SZ0XYO+UzII6R3B0Q+N9m/+DoAi2CmBe1W1pFSV6wea/T7zCXitxVq0J6piKzHhRFyUJT+KxEcs/ZXZkTwppR526n+MWZeGepDFILmRB8Lh74V+Y/iWnfr0C/84ZzTXJW/8Eeul0r1vNHFsTXE1dBOuDZlOeVBZwbPKLX3hx1vLNZXU7whK+ZlqN90yMsCGDQ4VbANdOpcrUN/mnQSYEdWn9OmCy3cFPsousfYk3M/PUmu34p20URwNHhTikJRTfvcphLSRHEoOyYispeRUkKjyUfC2E/bVbAsoPcCPO7U2E94OB0yZUb+NyNrOXH8MD59T+TbCk5mmI7NBQmnsPBlV1u7lA5n9nB+LZym8vYEPnuEt2kRIndmRrHZSFbroVQGJNOkKBJNIXDvnqc3S0vWmVwj73M/07g35p7//Dlo/wXjWiE03RO4TmMqir0l3QKgL0bEdlwGLcKxNifN5i2O1jSG4riXS0TPZXILZMdKJSKy+XSekmXJenEucwWCH1+f3sojyE7fESWjpVozB8ClgNUL/gEOYYXzFCfrIdB7ym5UQwgbVxjht2GihA/XVeVc/lYEiKqn1DFxmxIKgB7SRKf8LQfbsvsH3yI0xlwjanAx5lSK8V00atGxk4ES5vfxijhzic7BU92BdWw+AuhQLtIwkjoHVTsRAnGbCbhvaShHDEi4SU1PMH1ssJneZiecZ7dw9KvHCtXw==\"}","longitude":"0.00000000","deleted_time":0,"is_conflict":0,"todo_completed":0,"altitude":"0.0000","parent_id":"ff1c6c63dc474e43bb39ca69ea26141b","title":"","source_url":"","updated_time":1690208140887,"id":"1f7cb89cb721480ebe5040ac8d99a18c","todo_due":0,"author":"","user_created_time":1689677985231,"body":"","created_time":1689677985231,"type_":1}"

It should be possible to inspect a note by an ID using the plugin by:

  1. Opening the panel with at least one note selected
  2. Clicking on the table header
  3. Pasting a different ID
  4. Pressing "GO".

(Make sure you have a backup before doing this).

In Joplin's sync errors page, it might also make sense to add an "ignore" button by decryption errors in sync status (like we have for other types of sync errors).

YES!!
I saw I'm on the right item because it has no title among others. "permanently delete, restart, check sync status : now I have the same number of items as on all other Joplin instances, no sync error message, and (up to now) no warning elsewhere!
Thank you for your patience, and sorry for not having seen that possibility in the plugin...
Hervé

1 Like