Getting error while trying to sync with Nextcloud

Joplin version : 1.8.5
OS : Ubuntu 20.04 LTS

Hi,

I'm trying to set up joplin with my nextcloud server and I got an error when I try to do it via webdav.

This error is saying that https is not supported

Exactly I got :

"Last error: TypeError [ERR_INVALID_PROTOCOL]: Protocol "https:" not supported. Expected "http:"

I got 2FA on my nextcloud and already tried to get a new app password for it but same issue.

Anyone knows how to fix this issue?

Many thanks

Protocol "https:" not supported. Expected "http

Your URL starts with https, but you are using the port which is configured to http only.
Try your https port or change to http.

I'm using a hosted Nextcloud instance, specifically thegood.cloud, and I have honestly no clue how to use a different port. Any ideas?

Thanks in advance :slight_smile:

Hi !

Thanks for the answer

I fixed the issue by copy and paste WebDAV from file section (as requested) + using an OTP password because 2FA is activated on my Nextcloud account.
I also use a Nextcloud provider like you so it should resolve the issue.
I don’t know why it didn’t succeed the first time I tried but try to do it many times and it should be ok

1 Like

Hi everyone,

I'm also getting this error from a self-hosted nextcloud server.
But the webdav link is in http. So I can't tell whats the problem. I'm trying to connect from the linux desktop app:

Protocol "https:" not supported. Expected "http:" (Code ERR_INVALID_PROTOCOL)

And I don't use 2FA.

For me it sounds like your URL in Joplin is with https.

1 Like

ah, good point. It works with https ! thank you @JackGruber :smile:

I'm new to Joplin and I'm getting the same problem:
"Protocol "https:" not supported. Expected "http:" (Code ERR_INVALID_PROTOCOL)"
I've changed the URL in the sync setup from https to http, but I continue to get the same error message https not supported. Same error whether the URL is http or https. So I'm stuck. Please advise.

This will be fixed in the next version; for now you can just set the URL, save, and restart Joplin. After restarting, Joplin will work with the new URL.

Thanks, Roman. I did as you suggested and it solved the https problem! Thanks.
But now I have new errors. I'm using Kubuntu 20.04 and inputting as sync URL:
https://nextcloud05.webo.cloud/nextcloud/remote.php/WebDAV/Joplin
I have already created the Joplin folder on Webo. Is this URL correct?
The new sync error is

Completed: 2021-06-09 09:19

Last error: Error: MKCOL locks/: Unknown error 2 (404): 404 Not Found

404 Not Found


nginx/1.18.0 (Ubuntu)

And I've tried:
https://nextcloud05.webo.cloud/nextcloud/remote.php/DAV/Joplin

and get error:

PROPFIND : RemoteException: App not installed: (Exception Sabre\DAV\Exception\ServiceUnavailable) (503): <?xml version="1.0" encoding="utf-8"?> <d:error xmlns:d="DAV:" xmlns:s="http://sabredav.org/ns"> <s:sabredav-version>4.1.4</s:sabredav-version> <s:exception>Sabre\DAV\Exception\ServiceUnavailable</s:exception> <s:message>RemoteException: App not installed: </s:message> </d:error> (Code 503)

Any further help would be appreciated. David

OK, Roman. I got it! The correct URL is
nextcloud05.webo.cloud/remote.php/dav/files/USERNAME/

Hi.
I had the same problem, saving and restarting as per roman's instructions solved it.
Is there a way to see the files on Nextcloud ?
(I'm using a hosted version as of now, and it's my first time with Nextcloud).
Or is the reason I don't see them that the file path I gave to Joplin is https://cloud.something.fr/remote.php/webdav/ and not https://cloud.something.fr/remote.php/webdav/MyUserName ?
But then where to find my Nextclout complete URL ?
I don't see anything on the webclient for my hosted Nextcloud...

I recall in Nextcloud web UI there was a button in the lower left corner that when pressed shows your url that you can put in Joplin. I think that URL points to the root of you NC so you may want to create a folder like Joplin and add it to the URL

Indeed, there is a "parameter" button on the lower left, that gives me https://cloud.something.fr/remote.php/webdav/ as "use this address to access your files through Webdav".
I did per your suggestion create a folder Joplin (whose URL is https://cloud.something.fr/index.php/apps/files?dir=/Joplin&fileid=1****00 ) and used https://cloud.something.fr/remote.php/webdav/Joplin as the reference in Joplin and synchronized, but I still don't see anything.
I tried https://cloud.something.fr/remote.php/webdav/users/iutech
per this link but Joplin refused it at the "verify synchronization config" with a "this folder doesn't exist" message.

This URL looks correct to me.
What are you expecting to see? There should be a bunch of .md files in your Joplin folder, are they not there?

No, there's nothing.

Any errors in Joplin's log?

From "Aide - État de la synchronisation" :

## Fichiers joints

Non téléchargé : 0

Téléchargement en cours : 0

Téléchargé et déchiffré : 0

Téléchargé et chiffré : 0

Créé localement : 5

Erreur : 0

## Status de la synchronisation (objets synchro. / total)

Note: *06/*06

Folder: *8/*8

Resource: 5/5

Tag: 3/3

NoteTag: 3/3

MasterKey: 0/0

Revision: *61/*62

Total : *16/*17

Conflits : 0

A supprimer : 0

Should I look somewhere else ?

So, if that wasn't clear : apparently files are synchronized, but I still don't know where.