File system synchronisation appears to not work with mounted NAS via NFS4

Operating system

Linux

Joplin version

2.12.19

Desktop version info

Joplin 2.12.19 (prod, linux)

Client-ID: 736e419a0b9643d28dc3b6e0c6155a21
Sync-Version: 3
Profil-Version: 43
Unterstützter Schlüsselbund: Nein

Sync target

File system

What issue do you have?

When i try to sync to a mounted nas directory (via NFS4) joplin does not create any files during the synchronisation. The sync directory remains completely empty. However, joplin does not output any error message. Instead, i retrieve a successful synchronisation status (sorry for language):

Synchronisationsstatus (synchronisierte Elemente / Elemente insgesamt)
Note: 7/7
Folder: 1/1
Resource: 3/3
Tag: 0/0
NoteTag: 0/0
Revision: 2/2
Insgesamt: 13/13
 
Im Konflikt: 0
Zu löschen: 0

If i instead sync to a local directory, everything works as expected. Since i am able to load arbitrary .md files from the mounted directory into joplin, it seems that joplin has access to the directory in general. However, the instantiation of synchronisation files fails silently. I would expect a working synchronisation or an error message, if mounted directories are not supported. Is there something i am missing or did someone had the same problem and found a work-around? I am aware that there are other synchronisation possibilities offered by joplin or that one can use third party software to sync directories to nas. However, i would prefer to use the already integrated file system synchronisation if possible.

Log file

syncReport-1704905636475.txt (876 Bytes)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.