Feature request for Joplin Cloud: Mail with attachment

Hi,

I would like to add a feature request for the Joplin Cloud synchronisation.
I would like to be able to send mail also with an attachment to Joplin cloud.
When I do this now, the attachments are not added to the note in the inbox, only the text is added.

Kind regards, Ivo

Hello, Ivo

The current implementation of email to note should be appending a link to the attachment at the end of the note that was created.

In the example below you can see that I have a link to .PDF file:
image

If you still can't find your attachment, can you give me more information about the attachment content? Is there a specific fail type that you are trying to send? Did it fail to save other attachments from other emails before or it is the first time you tried to use the feature?

Also, if the email/attachment don't have any sensitive information I could instruct you how to send me the email file to help understand better what might be your issue.

Hi Pedro,

Thank you for your quick reply.
For example, when I attach a PDF in the Microsoft Outlook App for iOS, I do not get the PDF attached in the note.

I can forward you the mail so you can check why it is not working. Please let me know how to forward the mail to you.

It also happens when I attach a picture in Outlook for iOS.

Kind regards, Ivo

My address is pedrlz.frn+99@gmail.com

Hi Pedro,

Thanks, I just forwarded you the mail.
The same happened when I sent a picture today to the Joplin Cloud using Outlook on Windows.

Kind regards, Ivo

Hi Pedro,

This is how that test mail looks in my Joplin Inbox in iOS:

I think this usually happens when you open the note before it finished downloading the resources. Can you try to close and open the app again?


I tried forwarding your email to my account and it is working (last line is a link to the pdf, do you see that too?)

I tried forward to the inbox address that was used in the email, can you try to synchronize to see if it worked?

Hi Pedro,

When I open both your or mine in the inbox, I get the following (see below). It lists the attach, but it is not clickable.

Hmm, ok, I get it now. I will try to investigate it, thanks!

@IvoA1975 Is "Attachment download behavior" set to "Manual" in "Configuration > Synchronization"? If so, changing it to "Auto" might help.

The TestFlight release also has a few changes that might help with this. Specifically, it improves the display of HTML notes (emails are saved as HTML notes). The TestFlight release should be made stable and released to the AppStore some time in the next few weeks.

Thanks! Setting the sync to auto solved the problem, I had it indeed on manual.
I do need to restart Joplin though, otherwise I keep getting the earlier sent note.

For photos, I also tried this and it also shows up as attachment. It would be nicer if it shows as photo in the note. Is that a possibility?

Photos should also be supported -- I suspect that there's a bug.

I'm creating an issue on GitHub so we can track this. What version of Joplin are you using? (This can be found in Configuration > More information).

I am using Joplin 12.13.10 on iOS on both iPad and iPhone. Both have the same with the photo just being in the note as an attachment (so not showing in the note itself as a phote).
My Joplin under Linux does the same, that one is on Joplin version 2.13.8.

1 Like

I've created an issue: Email-to-note: Some image attachments not downloading · Issue #10027 · laurent22/joplin · GitHub

Thank you for reporting this!

You may want to delete this screenshot if it's no longer needed. There's some personal info on it.

Good one, I just deleted it

Thanks all for your effort, this issue has been successfully resolved.

Kind regards, Ivo

2 Likes